Bug #3429

When add a cluster,the ID of cluster is out-of-order

Added by 芳华 靳 almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:12/10/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:-
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.4

Description

steps:
1.log in as oneadmin
2.add a cluster,then delete it
3.repeat step 2 several times(about 10)
4.add a cluster

Actual Results:
4.the ID of cluster is 100

Expected Results:
4.the ID of cluster is sequential.

History

#1 Updated by 芳华 靳 almost 5 years ago

ID of the first 10 clusters is sequential.(ID from 0 to 9)

#2 Updated by Ruben S. Montero almost 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

There maybe some inconsistencies in your Database. Cluster IDs are supposed to start in 100. We are not able to reproduce this error (i.e. getting a cluster ID o <=99) in the last stable release (4.10). Could you upgrade and test it again?. Note also that clusters < 100 are system clusters and cannot be deleted.

Closing this as a worksforme, will reopen if the error can be reproduced.

Also available in: Atom PDF