Bug #3457

onevnet reserve should return the ID of the new VNET

Added by Ruben S. Montero over 6 years ago. Updated about 6 years ago.

Status:ClosedStart date:12/15/2014
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Client API & Library
Target version:Release 4.12
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.10, OpenNebula 4.8

Associated revisions

Revision 88f6e33c
Added by Carlos Martín about 6 years ago

Bug #3457: onevnet reserve returns the reservation vnet id

History

#1 Updated by Javi Fontan over 6 years ago

The problem is that the OCA call that creates the reservation returns nil on success. This also happens for add ar. Ruby OCA should be changed to return ID's when it creates new objects.

#2 Updated by Ruben S. Montero over 6 years ago

  • Target version changed from Release 4.10.2 to Release 4.12

#3 Updated by Carlos Martín about 6 years ago

  • Status changed from New to Closed
  • Assignee changed from Javi Fontan to Carlos Martín
  • Resolution set to fixed

Also available in: Atom PDF