Bug #3680

uninitialized constant EbtablesVLAN::COMMANDS (NameError)

Added by Rachel Chen over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:03/12/2015
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:Drivers - Network
Target version:Release 4.12.1
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.12

Description

After updating to 4.12.0, starting up instance gives erros:

Wed Mar 11 22:57:35 2015 [Z0][DiM][I]: New VM state is ACTIVE.
Wed Mar 11 22:57:35 2015 [Z0][LCM][I]: New VM state is BOOT_POWEROFF
Wed Mar 11 22:57:35 2015 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/64/deployment.1
Wed Mar 11 22:57:35 2015 [Z0][VMM][I]: ExitCode: 0
Wed Mar 11 22:57:35 2015 [Z0][VMM][I]: Successfully execute network driver operation: pre.
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: ExitCode: 0
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: Successfully execute virtualization driver operation: deploy.
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: Command execution fail: /var/tmp/one/vnm/ebtables/post (redacted) 'one-64'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: /var/tmp/one/vnm/ebtables/Ebtables.rb:30:in `ebtables': uninitialized constant EbtablesVLAN::COMMANDS (NameError)
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/ebtables/Ebtables.rb:52:in `block in activate'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/vm.rb:63:in `call'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/vm.rb:63:in `block in each_nic'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/vm.rb:62:in `each'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/vm.rb:62:in `each_nic'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/vnm_driver.rb:78:in `process'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/ebtables/Ebtables.rb:38:in `activate'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: from /var/tmp/one/vnm/ebtables/post:28:in `<main>'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: ExitCode: 1
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: error: failed to get domain 'one-64'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: error: Domain not found: no domain with matching name 'one-64'
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: ExitCode: 0
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: Successfully execute virtualization driver operation: cancel.
Wed Mar 11 22:57:36 2015 [Z0][VMM][I]: Failed to execute network driver operation: post.
Wed Mar 11 22:57:36 2015 [Z0][VMM][E]: Error deploying virtual machine
Wed Mar 11 22:57:36 2015 [Z0][LCM][I]: Fail to boot VM. New VM state is POWEROFF

After changing affecting code from:

    def ebtables(rule)
        OpenNebula.exec_and_log("#{COMMANDS[:ebtables]} -A #{rule}")
    end

To:

    def ebtables(rule)
        OpenNebula.exec_and_log("#{VNMMAD::VNMNetwork::COMMANDS[:ebtables]} -A #{rule}")
    end

The problem is resolved.

Associated revisions

Revision 1b2dc889
Added by Ruben S. Montero over 5 years ago

bug #3680: Use command function to generate ebtables commands

Revision 1d02bed6
Added by Ruben S. Montero over 5 years ago

bug #3680: Use command function to generate ebtables commands

(cherry picked from commit 1b2dc88929beaf00e5216ca8ac21b4a097ee8e12)

History

#1 Updated by Ruben S. Montero over 5 years ago

  • Category set to Drivers - Network
  • Status changed from Pending to Assigned
  • Assignee set to Ruben S. Montero
  • Target version set to Release 4.12.1

THANKS for the Feedback!!!

#2 Updated by Ruben S. Montero over 5 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

There are also other functions with this error, I've updated the driver file to make use of the command() function that abstract the command line generation.

You can replace the driver file with that on one-4.12 branch. Do not forget to run onehost sync after that

Cheers

Also available in: Atom PDF