Bug #3719

LDAP group search does not work with net-ldap 0.8.0

Added by Javi Fontan almost 6 years ago. Updated over 5 years ago.

Status:ClosedStart date:03/25/2015
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Auth
Target version:Release 4.14
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.12

Description

ruby 1.8 only supports net-ldap <= 0.8.0 but this version does not support attributes parameter in search call:

    def is_in_group?(user, group)                                                    
        result=@ldap.search(                                                         
                    :base   => group,                                                
                    :attributes => @options[:group_field],                           
                    :filter => "(#{@options[:group_field]}=#{user.first})")     

History

#1 Updated by Ruben S. Montero almost 6 years ago

  • Status changed from Pending to New
  • Target version set to Release 4.12.1

#2 Updated by Javi Fontan almost 6 years ago

  • Target version changed from Release 4.12.1 to Release 4.14

#3 Updated by Ruben S. Montero over 5 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Also available in: Atom PDF