Bug #3812

Opennebula does not reports debug logs for "system" "syslog"

Added by Alvaro Simon over 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:05/21/2015
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Core & System
Target version:Release 4.14.2
Resolution:invalid Pull request:
Affected Versions:OpenNebula 4.12

Description

Dear opennebula developers

We are using system syslog in our oned conf instead of file. We found that debug [D] logs are missing, opennebula only reports info [I] and error [E] logs, our log level is set to 3:

LOG = [
debug_level = 3,
system = "syslog"
]

do you know if this is a normal behaviour?, in we use file logs everything is logged as usual.

Cheers
Alvaro

History

#1 Updated by Ruben S. Montero almost 5 years ago

  • Target version set to Release 4.14.2

#2 Updated by Carlos Martín almost 5 years ago

  • Assignee set to Carlos Martín

#3 Updated by Carlos Martín almost 5 years ago

Hi,

I can't reproduce this bug, trying both 4.12 and 4.14.
Can you think of anything else that may be triggering this problem for you?

By the way, the oned.conf read by opennebula is also logged in the first lines after oned start. Could you double check that that there isn't any other LOG attribute with a lower debug_level?

LOG=DEBUG_LEVEL=3,SYSTEM=syslog

#4 Updated by Alvaro Simon almost 5 years ago

Hi Carlos

Sorry for the noise, in fact it was a rsyslogd + kibana conf issue, is not related with ONE at all. Please close this ticket and sorry again for the noise :-(

Cheers and thanks!
Alvaro

Carlos Martín wrote:

Hi,

I can't reproduce this bug, trying both 4.12 and 4.14.
Can you think of anything else that may be triggering this problem for you?

By the way, the oned.conf read by opennebula is also logged in the first lines after oned start. Could you double check that that there isn't any other LOG attribute with a lower debug_level?
[...]

#5 Updated by Carlos Martín almost 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to invalid

Also available in: Atom PDF