Bug #3839

opennebula-common rpm package fails kickstart installation

Added by Bogdan Suta over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:06/15/2015
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Packaging
Target version:Release 4.14
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.12

Description

On automated installs (kickstart) on CentOS 7 when you try to install OpenNebula 4.12 the installation fails when installing the opennebula-common package.

The reason for this is the package does not specify enough dependencies.

On a kickstart installation the administrator cannot order the packages that are installed. Opennebula-common needs a few common utilities (mkdir, chcon, groupadd etc.) that are part of the shadow-utils, coreutils and glibc-common packages.

Solution:
Add the following line to the opennebula-common spec file:

Requires shadow-utils, coreutils, glibc-common

Also might be an idea to include dependencies for ruby gems in rpm format so "install_gems" is no longer necessary.

Thank you.

History

#1 Updated by Ruben S. Montero over 4 years ago

  • Target version set to Release 4.14

#2 Updated by Ruben S. Montero over 4 years ago

  • Assignee set to Jaime Melis

#3 Updated by Jaime Melis about 4 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Applied. Thanks!

Also available in: Atom PDF