Request #3901

Shareable persistent disk image between several VMs

Added by Eugene W over 5 years ago. Updated over 5 years ago.

Status:ClosedStart date:07/30/2015
Priority:HighDue date:
Assignee:-% Done:

0%

Category:-
Target version:-
Pull request:

Description

I'm using UpenNebula 4.12.1.
I want to share a persistent image between two VMs to set up an Oracle Cluster Filesitem 2.

Libvirt support option <shareable/> for this case, for example, a piece of xml config below.

<disk type='block' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source dev='/var/lib/kvm/disk.1'/>
      <target dev='vdb' bus='virtio'/>
      <shareable/>
      <address type='pci' domain='0x0000' bus='0x02' slot='0x04' function='0x0'/>
    </disk>

But OpenNebula by design can not use the same persistent image in more than one VM.
This is a great disadvantage.

Maybe is it possible to hack the current OpenNebula version for use <shareable/> option for images?
Maybe possible to add some custom Attributes to image or some other solution?

In any case it is necessary to consider the function "Shareable persistent disk image between several VMs"


Related issues

Related to Backlog #2659: Add SHAREABLE option to libvirt disks Pending 01/20/2014

History

#1 Updated by Ruben S. Montero over 5 years ago

  • Related to Backlog #2659: Add SHAREABLE option to libvirt disks added

#2 Updated by Ruben S. Montero over 5 years ago

  • Tracker changed from Feature to Request
  • Category deleted (Sunstone)
  • Status changed from Pending to Closed

closing as duplicate

Also available in: Atom PDF