Feature #3958

migrate option on VMs from FAILED host to call PROLOG_MIGRATE bofore BOOT

Added by Anton Todorov about 5 years ago. Updated over 4 years ago.

Status:ClosedStart date:08/31/2015
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 5.0
Resolution:fixed Pull request:

Description

There is HOST_HOOK to handle VM-s when a vm host node enter FAIL state with three possible solutions to rescue the VMs:
1. delete VM
2. delete-recreate VM
3. "move" VM to another host

The problem is that there is no way to "rescue" VMs with non-persistent VM images when they are backed with block devices without native support in libvirt

Here is a list of the affected addons
https://github.com/OpenNebula/addon-iscsi
https://github.com/OpenNebula/addon-iscsi-equallogic
https://github.com/OpenNebula/addon-iscsi-v7000
https://github.com/OpenNebula/addon-storpool

The solution is before calling BOOT to call PROLOG_MIGRATE
see assigned pull request (https://github.com/OpenNebula/one/pull/70)

If you decide that this contribution needs contributors license agreement do not hesitate to contact to arrange it.

Associated revisions

Revision 82336ddc
Added by Ruben S. Montero over 4 years ago

feature #3958: Add PROLOG_MIGRATE_FAILURE to prolog_failure callback and
recover actions

Revision dafeeaf9
Added by Ruben S. Montero over 4 years ago

feature #3958: Merge common code for PROLOG_MIGRATE_UNKNOWN

History

#1 Updated by Ruben S. Montero about 5 years ago

  • Tracker changed from Feature to Backlog
  • Target version changed from 79 to Release 5.0

Hi Anton,

First thank you for this thorough patch :) We think this is a good addition to improve FT for VMs for a wider range of storage backends. This is too close for the next release. Just moving it to include it after the release.

Again thanks for this

Ruben

#2 Updated by Ruben S. Montero almost 5 years ago

  • Tracker changed from Backlog to Feature

#3 Updated by Ruben S. Montero over 4 years ago

  • Tracker changed from Feature to Backlog
  • Priority changed from Normal to High
  • Target version deleted (Release 5.0)

We are now behind schedule for this release 5.0 .. moving this to the backlog

#4 Updated by Anton Todorov over 4 years ago

Hi,

I am confused.

The patch was made before 4.14 release but it was "too close" for 4.14, now it is "behind schedule" for 5.0. What's going on?

As you already have native iSCSI support I would like to note that the same issue is valid for iSCSI block devices.

It is true that I've found a loophole in the LCM state machine and have a workaround but it is working too slow because there are several LCM state changes and waiting for timeouts instead of just single native one.

.
Anton

#5 Updated by Ruben S. Montero over 4 years ago

  • Tracker changed from Backlog to Feature
  • Target version set to Release 5.0

Sorry, I got the wrong issue number ;)

#6 Updated by Ruben S. Montero over 4 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

This is now in master, added logic to handle callback on prolog_failure and recover action. Also I've merged the logic of PROLOG_MIGRATE_UNKNOWN with equivalent states.

THANKS again and sorry for the misunderstanding

Also available in: Atom PDF