Bug #4061

disk sizes not updated when VM is in PowerOff state

Added by Anton Todorov almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:10/15/2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Core & System
Target version:Release 4.14.2
Resolution:wontfix Pull request:
Affected Versions:OpenNebula 4.12, OpenNebula 4.14

Description

how to reproduce:
  • poweroff VM
  • take disk snapshot

result: snapshot is created, the snapshot tree is updated in sunstone but the size of the snapshot is not updated. It stays on -/<DISK SIZE>
(I've managed to lost all reported sizes, but can't reproduce reliable)

expected: vmm/kvm/pool to be called at least one to refresh sizes.(or to be called not only on running state but on poweroff and suspended too)

Kind Regards,
Anton Todorov

History

#1 Updated by Ruben S. Montero almost 5 years ago

  • Target version set to Release 4.14.2

#2 Updated by Javi Fontan almost 5 years ago

  • Category changed from Drivers - Monitor to Core & System

#3 Updated by Ruben S. Montero almost 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to wontfix
  • Affected Versions OpenNebula 4.12 added

Hi Anton,

I'm afraid this is the expected behavior. Note that a VM in poweroff is out of the hypervisor list so the probes cannot get the VM ID's or get the system datastore path. So till the VM is powered on just the virtual size of the snapshots will be reported.

Cheers

Ruben

Also available in: Atom PDF