Bug #4202

opensans.woff is installed into css, not css/opensans

Added by Rolandas Naujikas over 4 years ago. Updated about 4 years ago.

Status:ClosedStart date:11/25/2015
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Packaging
Target version:Release 5.0
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 4.14

Description

install.sh installs opensans.woff into $SUNSTONE_LOCATION/public/css, but referenced as css/opensans/opensans.woff.

Workaround ln -s ../opensans.woff css/opensans/opensans.woff works, but install.sh should be corrected or reference inside app.min.css.

It is for minified version.

History

#1 Updated by Ruben S. Montero over 4 years ago

  • Target version set to Release 5.0

#2 Updated by Rolandas Naujikas over 4 years ago

Please correct it in one-4.14. It is one (or two) lines change.

#3 Updated by Jaime Melis over 4 years ago

  • Category changed from Sunstone to Packaging
  • Assignee set to Jaime Melis
  • Target version changed from Release 5.0 to 82

#4 Updated by Ruben S. Montero over 4 years ago

  • Target version changed from 82 to Release 5.0

#5 Updated by Javi Fontan about 4 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

This does not happen to me in 5.0 or 4.14 branches.

#6 Updated by Rolandas Naujikas about 4 years ago

It happens when install to directory. For e.g.

./install.sh -d /var/lib/one/4.14.2e -p

As a workaround my install script has

mv -f /var/lib/one/4.14.2e/lib/sunstone/public/css/opensans.woff /var/lib/one/4.14.2e/lib/sunstone/public/css/opensans/

The problem is in install.sh file:

INSTALL_SUNSTONE_PUBLIC_MINIFIED_FILES=(
...
  SUNSTONE_PUBLIC_CSS_FILES:$SUNSTONE_LOCATION/public/css
...

All files in $SUNSTONE_PUBLIC_CSS_FILES are copied to root at $SUNSTONE_LOCATION/public/css including opensans.woff with

cp -RL $SRC_DIR/$1 $DESTDIR$2

Possible solution would be remove opensans.woff from SUNSTONE_PUBLIC_CSS_FILES and create separate rule for it.

My Linux distribution is Debian 8.

Also available in: Atom PDF