Bug #4276

snap_create not working for combination of qcow2 and ssh TM

Added by Ondrej Hamada almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:01/07/2016
Priority:NormalDue date:
Assignee:OpenNebula Systems Support Team% Done:

0%

Category:Drivers - Storage
Target version:Release 5.0
Resolution:fixed Pull request: https://github.com/OpenNebula/one/pull/81
Affected Versions:OpenNebula 4.14

Description

OpenNebula 4.14.2, Debian 8

image datastore uses qcow2 TM driver
system datastore uses ssh TM driver

When creating a snapshot via snap_create, the operation fails. It is caused by the snap_create operation in qcow2 TM driver that looks for previous snapshot on the frontend node. But the system datastore uses ssh TM driver, therefore the disk image and previous snapshots are available on the remote host only.

A backslash should be inserted into on the line 79 of src/tm_mad/qcow2/snap_create - to run the readlink on remote host:
PREVIOUS_SNAP=\$(readlink $SYSTEM_DS_DISK_PATH)

https://forum.opennebula.org/t/snap-create-for-combination-of-qcow2-and-ssh-tm/1659

History

#1 Updated by Ruben S. Montero almost 4 years ago

  • Pull request set to https://github.com/OpenNebula/one/pull/81

#2 Updated by Ruben S. Montero almost 4 years ago

  • Target version set to Release 5.0

#3 Updated by OpenNebula Systems Support Team over 3 years ago

  • Status changed from Pending to Closed
  • Assignee set to OpenNebula Systems Support Team
  • Resolution set to fixed

Also available in: Atom PDF