Bug #4517

Snapshot DISK_SIZE monitoring information ignored

Added by Stefan Kooman almost 5 years ago. Updated almost 5 years ago.

Status:ClosedStart date:06/03/2016
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - Storage
Target version:Release 5.0
Resolution:fixed Pull request:
Affected Versions:Development

Description

For VM's with (qcow2) snapshots the DISK_SIZE information is ignored:

Jun 3 11:17:30 test-oned2 oned25568: [VM 189][Z0][VMM][E]: Ignoring monitoring information, error:syntax error, unexpected EQUAL, expecting COMMA or CBRACKET at line 1, columns 37:38. Monitor information was: DISK_SIZE=[ID=0,SIZE=] SNAPSHOT_SIZE=[ID=0,DISK_ID=0,SIZE=1230] SNAPSHOT_SIZE=[ID=1,DISK_ID=0,SIZE=1] SNAPSHOT_SIZE=[ID=2,DISK_ID=0,SIZE=147] SNAPSHOT_SIZE=[ID=3,DISK_ID=0,SIZE=1] DISK_SIZE=[ID=1,SIZE=1] DISK_SIZE=[ID=2,SIZE=]

Associated revisions

Revision 93dfb43d
Added by Javi Fontan almost 5 years ago

bug #4517: skip disk/snaps that cannot be monitored

History

#1 Updated by Ruben S. Montero almost 5 years ago

  • Category set to Drivers - Storage
  • Assignee set to Javi Fontan
  • Target version set to Release 5.0

#2 Updated by Javi Fontan almost 5 years ago

Now an extra check is done so snapshots and disks that can not be monitored are not shown.

#3 Updated by Javi Fontan almost 5 years ago

I am not able to reproduce the problem you're describing. Some changes are added to skip disks that can not be monitored. Still I would like to know why this is happening. If this happens again can you tell me the configuration of the machine?

#4 Updated by Ruben S. Montero almost 5 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Let's assume this fixes the issue. We'll reopen if needed

Also available in: Atom PDF