Bug #4586

Missing dependencies for opennebula-flow debian/ubuntu package

Added by Daniel Dehennin over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:06/21/2016
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Packaging
Target version:Release 5.0.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

Hello,

The opennebula-flow package should depends on the following ruby packages:

After installing them by hand, the service starts.

Regards.

History

#1 Updated by Ruben S. Montero over 2 years ago

  • Category set to Packaging
  • Status changed from Pending to New
  • Target version set to Release 5.2

#2 Updated by Ruben S. Montero over 2 years ago

  • Target version changed from Release 5.2 to Release 5.0.2

#3 Updated by Jaime Melis over 2 years ago

  • Assignee set to Jaime Melis

#4 Updated by Jaime Melis over 2 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Fixed:

added ruby-treetop for ubuntu-14.04, ubuntu-16.04 and debian 8
added ruby-parse-cron only for ubuntu-16.04 (not available for ubuntu-14.04, and debian 8)

By the way, remember that after installing OpenNebula or doing an upgrade, you should run install_gems [1] (although adding these deps is a good idea :-) )

[1] http://docs.opennebula.org/5.0/deployment/opennebula_installation/frontend_installation.html#step-4-ruby-runtime-installation

#5 Updated by Austin Che over 2 years ago

After the upgrade to version 5.0.2, opennebula-flow won't start on ubuntu 14.04 because the version of ruby-treetop in ubuntu repo is 1.4.14. Although install_gems installs 1.6.8, oneflow will not start with error

/usr/lib/one/oneflow/lib/models/role.rb:23:in `<top (required)>': treetop gem version must be >= 1.6.3. Current version is 1.4.14 (RuntimeError)

#6 Updated by Austin Che over 2 years ago

A workaround to force the uninstall of the package: dpkg --ignore-depends -P ruby-treetop

Also available in: Atom PDF