Bug #4649

the vbs file for Windows contextualization has got an error or the documentation is wrong.

Added by Gunwoo Gim almost 5 years ago.

Status:PendingStart date:07/17/2016
Priority:HighDue date:
Assignee:-% Done:


Target version:-
Resolution: Pull request:
Affected Versions:OpenNebula 5.0


I guess the chatting log on IRC is sufficient for this issue. at the moment I had a partition labeled "CONTEXT" with the drive letter D: assigned on it and this partition was preventing the contextualization of the VM.

Nicho1as | it still doesn't work though now it doesn't pop up the error message of unsuccessful compilation at line 1 character 1 | when I double click the vbs file

Nicho1as | pfak: fixed it with my makeshift patch to the vbs file | fixed it by adding these 3 lines before the last "End If"
Set objShell = CreateObject("Wscript.Shell")
objShell.Run("powershell -NonInteractive -NoProfile -NoLogo -ExecutionPolicy Unrestricted -file " & "C:" & "\context.ps1"

| the documentation says "Downloads these two files to C:\:" (the ps1 and vbs from GitHub)                                 
| but the vbs script wants to find the ps1 file in a drive letter that is assigned to a partition labeled "CONTEXT"   
| I guess some of the developers should edit either the document or the vbs code.                                          
| should I report it on to the dev.opennebula.org or does it suffice to report here?                                         
| let me know later please.

Also available in: Atom PDF