Bug #4732

Virtual Router: predefined network in template are not displayed during instantation

Added by EOLE Team over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:08/22/2016
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Sunstone
Target version:Release 5.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

Hello,

I cloned the alpine-vrouter (KVM) template to predefine the network and let my users start their gateway more easily (note that academie NIC does not use NETWORK_UNAME to use user's one):

CONTEXT = [
  NETWORK = "YES",
  SSH_PUBLIC_KEY = "$USER[SSH_PUBLIC_KEY]" ]
CPU = "0.02" 
DISK = [
  IMAGE_ID = "13884" ]
GRAPHICS = [
  LISTEN = "0.0.0.0",
  TYPE = "VNC" ]
LOGO = "images/logos/linux.png" 
MEMORY = "128" 
NIC = [
  NETWORK = "EOLE",
  NETWORK_UNAME = "nebula" ]
NIC = [
  NETWORK = "academie" ]
NIC_DEFAULT = [
  MODEL = "virtio" ]
USER_INPUTS = [
  CPU = "O|fixed|| |0.02",
  MEMORY = "M|range||128..512|128",
  VCPU = "O|range||2..4|2" ]
VCPU = "2" 
VROUTER = "YES" 

When I instantiate that Vrouter template, I do not see the predefined networks (see instantiate-vrouter-no-networks.png).

I think the information should be displayed as they are use by the Vrouter VM instance (see vrouter-instance-has-networks.png).

Regards.

instantiate-vrouter-no-networks.png (29.5 KB) EOLE Team, 08/22/2016 11:38 AM

vrouter-instance-has-networks.png (55.7 KB) EOLE Team, 08/22/2016 11:38 AM

wrong-network-topology.png (86.6 KB) EOLE Team, 08/22/2016 12:16 PM


Related issues

Related to Request #4750: Virtual Router Templates Pending 08/26/2016

Associated revisions

Revision 2a6d38ae
Added by Carlos Martín over 4 years ago

Bug #4732: Disable NIC edit in wizard for VR VM Templates

History

#1 Updated by EOLE Team over 4 years ago

This results in a wrong network topology schema: the Virtual Router is not displayed between VNet academie and VNet EOLE (see wrong-network-topology.png).

Regards.

#2 Updated by Ruben S. Montero over 4 years ago

  • Target version set to Release 5.2

#3 Updated by Carlos Martín over 4 years ago

The bug here is actually that the vm templates used for virtual routers are not supposed to have NICs.
If any NIC is defined for the VR, the template ones are overwritten. In this case the VR has no NICs, and the ones from the vm template remain.

Maybe what we should do is remove the NIC section from the VR VM template wizard

#4 Updated by EOLE Team over 4 years ago

Carlos Martín wrote:

Maybe what we should do is remove the NIC section from the VR VM template wizard

I'm not sure about this, I like the idea to make my users life easier when possible.

Our use case may be quite specific but each user need the same VR, using the same network names but without the UNAME to use their own.

I think that the Create Virtual Router and Instantiate Virtual Router Template wizards could use networks from VR VM template if any:

  • user starts a full prepared VR with 2 clics
  • user can modify the configuration as she wants:
    • add other networks
    • change any networks without touching the others
    • remove some networks

It's like what we can do with VMs.

Regards.

#5 Updated by Carlos Martín over 4 years ago

EOLE Team wrote:

It's like what we can do with VMs.

The problem here is that NICs are managed by the Virtual Router, not the Virtual Machine.
And you can't pre-create a predefined Virtual Router, because Virtual Router Templates do not exist.

Sunstone groups VM Templates that can be used to create VR VMs under "Virtual Router VM Templates". But those are for the VMs that the VR will instantiate internally, not for the VR itself. The same way you can't predefine the Virtual Router name, or keealive password, you can't pre-define NICs.

So I see this more like a request for new Virtual Router Templates, instead of a bug. Hope that makes sense.

In the short-term I think the best thing to do is hide NICs from "VR VM Templates", and open a backlog ticket for new "VR Templates".
What do you think?

#6 Updated by EOLE Team over 4 years ago

Carlos Martín wrote:

EOLE Team wrote:

It's like what we can do with VMs.

The problem here is that NICs are managed by the Virtual Router, not the Virtual Machine.
And you can't pre-create a predefined Virtual Router, because Virtual Router Templates do not exist.

Sunstone groups VM Templates that can be used to create VR VMs under "Virtual Router VM Templates". But those are for the VMs that the VR will instantiate internally, not for the VR itself. The same way you can't predefine the Virtual Router name, or keealive password, you can't pre-define NICs.

So I see this more like a request for new Virtual Router Templates, instead of a bug. Hope that makes sense.

In the short-term I think the best thing to do is hide NICs from "VR VM Templates", and open a backlog ticket for new "VR Templates".
What do you think?

Ok now I understand and I agree to the proposal.

Regards.

#7 Updated by Carlos Martín over 4 years ago

#8 Updated by Carlos Martín over 4 years ago

  • Status changed from Pending to Closed
  • Assignee set to Carlos Martín
  • Resolution set to fixed

Fixed as discussed. The wizard hides the NICs when the VM Template is meant for Virtual Router VMs.

Added a new request ticket for the Virtual Router Templates: #4750

Also available in: Atom PDF