Feature #474

Add/Remove Leases from a Fixed Virtual Network

Added by Tino Vázquez almost 9 years ago. Updated almost 9 years ago.

Status:ClosedStart date:01/27/2011
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Core & System
Target version:Release 2.2
Resolution:fixed Pull request:

Description

Two new operations will be made available to obtain this:

add_lease ( vnet, lease ) --> will check that is not present yet
remove_lease(vnet, lease) --> will check the lease is not being used.

where lease is IP, MAC or MAC/IP.


Related issues

Duplicated by Feature #404: Virtual Network Modification Closed 11/09/2010
Duplicates Feature #384: Add network groups Closed 11/01/2010

Associated revisions

Revision c5734c93
Added by Carlos Martín almost 9 years ago

Feature #474: First commit for add/remove leases feature

Revision 1ce81994
Added by Ruben S. Montero almost 9 years ago

feature #474: some refactor of the error strings

Revision 6850348e
Added by Carlos Martín almost 9 years ago

Feature #474: Core unit tests for add/remove leases feature

Revision 2d246ee0
Added by Carlos Martín almost 9 years ago

Feature #474: Add/remove leases feature for Java OCA

Revision 9658db39
Added by Carlos Martín almost 9 years ago

Feature #474: Small change to make Java OCA consistent as a wrapper for the XML-RPC API

Revision 0fc3e3b8
Added by Jaime Melis over 2 years ago

Merge pull request #474 from abelCoronado93/bug-layout-instantiate

Solved bug in VM instantiate layout

History

#1 Updated by Tino Vázquez almost 9 years ago

  • Category set to Core & System
  • Target version set to Release 2.2

#2 Updated by Carlos Martín almost 9 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100
  • Resolution set to fixed

#3 Updated by Matt Lavin almost 9 years ago

I think that feature #349 should be marked as a duplicate of this one as well.

Also available in: Atom PDF