Bug #4744

Wrong order of commands in 4.4.x to 5.0 upgrade instructions

Added by Mariano Guezuraga over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:08/25/2016
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Documentation
Target version:Release 5.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

In http://docs.opennebula.org/5.0/intro_release_notes/upgrades/upgrade_44.html, in the "Database upgrade", it is stated:

  1. Do 'onedb upgrade'
  2. "Now execute the following DB patch"

However, doing the upgrade first and applying the patch later, results in:

[oneadmin@frontend ~]$ onedb patch -v -u oneadmin -d opennebla /usr/lib/one/ruby/onedb/patches/4.14_monitoring.rb
MySQL Password:
Version read:
Shared tables 4.90.0 : Database migrated from 4.11.80 to 4.90.0 (OpenNebula 4.90.0) by onedb command.
Local tables  4.90.0 : Database migrated from 4.13.85 to 4.90.0 (OpenNebula 4.90.0) by onedb command.

Version mismatch: patch file is for version
Shared: 4.11.80, Local: 4.13.85

Current database is version
Shared: 4.90.0, Local: 4.90.0

After re-doing my test, and executing the patch before:

[oneadmin@frontend ~]$ onedb patch -v -u oneadmin -d opennebula /usr/lib/one/ruby/onedb/patches/4.14_monitoring.rb
MySQL Password:
Version read:
Shared tables 4.11.80 : OpenNebula 4.14.2 daemon bootstrap
Local tables  4.13.85 : OpenNebula 4.14.2 daemon bootstrap

  > Running patch /usr/lib/one/ruby/onedb/patches/4.14_monitoring.rb
  > Done

  > Total time: 0.98s

Associated revisions

Revision 56c364d9
Added by Carlos Martín over 4 years ago

Bug #4744: Remove the need for a separate patch for upgrades from version < 4.14

History

#1 Updated by Ruben S. Montero over 4 years ago

  • Target version set to Release 5.2

#2 Updated by Carlos Martín over 4 years ago

  • Status changed from Pending to Closed
  • Assignee set to Carlos Martín
  • Resolution set to fixed

Fixed for 5.2

Also available in: Atom PDF