Bug #4764

Hotplug of ceph volatile disks doesn't work

Added by Javi Fontan about 3 years ago. Updated about 2 years ago.

Status:ClosedStart date:09/05/2016
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:Drivers - VM
Target version:Release 5.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.0

Description

Hotplug xml file is generated with the wrong info when hot plugging a volatile disk. Using ceph tm for System datastore.

Mon Sep  5 12:16:53 2016 [Z0][VMM][E]: attach_disk: Command "virsh --connect qemu:///system attach-device one-14 /var/lib/one//datastores/0/14/disk.2.attach" failed: error: Failed to attach device from /var/lib/one//datastores/0/14/disk.2.attach
Mon Sep  5 12:16:53 2016 [Z0][VMM][I]: error: Cannot access storage file '/var/lib/one//datastores/0/14/disk.2' (as uid:9869, gid:9869): No such file or directory
Mon Sep  5 12:16:53 2016 [Z0][VMM][E]: Could not attach /var/lib/one//datastores/0/14/disk.2 (vdb) to one-14

Test:

# cat volatile
DISK = [
  TYPE = fs,
  SIZE = 128,
  DEV_PREFIX = vd,
  FORMAT = raw
]

# onevm disk-attach 14 --file volatile

Associated revisions

Revision 473db733
Added by Jaime Melis about 3 years ago

B #4764: Hotplug of ceph volatile disks doesn't work

History

#1 Updated by Ruben S. Montero about 3 years ago

  • Assignee set to Ruben S. Montero

#2 Updated by Jaime Melis about 3 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

#3 Updated by Anton Zubkov about 2 years ago

Not fixed.

Also available in: Atom PDF