Bug #4784

Unsuccessful Hotplug of Volatile disks causes RBD to not be cleared upon VM termination

Added by Wesley Dillingham over 4 years ago. Updated over 4 years ago.

Status:ClosedStart date:09/15/2016
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 5.2
Resolution:duplicate Pull request:
Affected Versions:OpenNebula 5.0

Description

I attempted to create a volatile swap disk which fails as it appears Nebula attempts to use RBD Kernel driver to map the device and newer RBD features (object map, exclusive lock) are not supported by RBD kernel driver.

The problem is:
Upon terminating the virtual machine the volatile disks which were created, yet never attached to the VM are not cleared out of ceph.
The Volatile disks which were part of the template, however, are removed.

It is unclear to me if they aren't removed because they are not part of the template or because they weren't successfully attached initially.

I imagine that it is because they did not attach as if you wanted a disk to persist beyond termination you would use a persistent datablock.

I suspect the desired outcome is that even volatile disks which do not successfully attach should be cleaned up upon VM termination.

Nebula 5.0.2 Ceph 10.2.2


Related issues

Duplicates Bug #4781: Delete new image when mkimage/mkswap fails Closed 09/15/2016

History

#1 Updated by Javi Fontan over 4 years ago

  • Duplicates Bug #4781: Delete new image when mkimage/mkswap fails added

#2 Updated by Javi Fontan over 4 years ago

  • Status changed from Pending to Closed
  • Target version set to Release 5.2
  • Resolution set to duplicate

See #4781 for a fix.

Also available in: Atom PDF