Feature #4801

Force even memory values for MEM attribute

Added by Carlos Cesario almost 3 years ago. Updated almost 2 years ago.

Status:ClosedStart date:09/19/2016
Priority:HighDue date:
Assignee:Abel Coronado% Done:

100%

Category:Sunstone
Target version:Release 5.4.3
Resolution:fixed Pull request:

Description

Hello,

After I type wrong memory value (1027 MB) instead 1024 MB, and try instantiate new VM, I got error in vCenter (vcenter_error.png)
After check it, the vCenter/vSphere only allow values increased from 4 to 4 values, in this case the allowed values are 1028 MB or 1024 MB.

Other point is, after this problem, I tried delete the instance by Sunstone GUI (Recover/Delete). After this the instance it was deleted on Sunstone GUI, but remain on vCenter, then I needed delete it manually.

best regards,

-Carlos

vcenter_error.png (100 KB) Carlos Cesario, 09/19/2016 06:26 PM

Associated revisions

Revision f7633ae1
Added by Abel Coronado almost 2 years ago

F #4801: Don't allow odd size memory for vCenter templates (#516)

  • F #4801: Don't allow odd size memory for vCenter templates
  • F #4801: Only multiples of 4 for size memory for vCenter templates

Revision 50781699
Added by Abel Coronado almost 2 years ago

F #4801: Don't allow odd size memory for vCenter templates (#516)

  • F #4801: Don't allow odd size memory for vCenter templates
  • F #4801: Only multiples of 4 for size memory for vCenter templates

(cherry picked from commit f7633ae1d0aa9f140d352cf18e75eb7b70af5eeb)

History

#2 Updated by Tino Vázquez almost 3 years ago

  • Status changed from Pending to New
  • Target version set to Release 5.2
  • Affected Versions Development added

Add a check in deploy operation to ascertain 4 by 4 increase.

#3 Updated by Miguel Ángel Álvarez Cabrerizo almost 3 years ago

  • Category changed from vCenter to Core & System
  • Target version changed from Release 5.2 to Release 5.4

First part of the issue has been reproduced. VM fails to boot due to "GenericVmConfigFault: Memory (RAM) size (257) is invalid." This issue is not only related with vCenter so category has been changed.

Sunstone allows to use an odd number for RAM memory so it would be a good idea to check that value before submitting. As RAM memory may be a multiple of 2 MB or 4 MB depending on the hypervisor and architecture (see discussion http://serverfault.com/questions/771922/allocating-non-standard-memory-quantities-to-virtual-machines) forcing the number to be only a multiple of 4 wouldn't be appropiate. So the odd number check would be the right path. Also Core support for this feature should be added when selecting RAM memory for CLI users.

The second part of the issue already has a ticket assigned: http://dev.opennebula.org/issues/4648

#4 Updated by Carlos Cesario almost 3 years ago

Hi Miguel,

Thank you by your noted!

-Carlos

#5 Updated by Ruben S. Montero almost 3 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from vCenter :: When instantiated VM with wrong memory value to Force even memory values for MEM attribute

#6 Updated by OpenNebula Systems Support Team over 2 years ago

  • Tracker changed from Feature to Backlog

#7 Updated by Ruben S. Montero about 2 years ago

  • Target version changed from Release 5.4 to Release 5.6

#8 Updated by Tino Vázquez almost 2 years ago

  • Tracker changed from Backlog to Feature
  • Assignee set to Abel Coronado
  • Target version changed from Release 5.6 to Release 5.4.2

#9 Updated by Tino Vázquez almost 2 years ago

  • Category changed from Core & System to Sunstone

#10 Updated by Abel Coronado almost 2 years ago

  • % Done changed from 0 to 100

#11 Updated by Ruben S. Montero almost 2 years ago

  • Target version changed from Release 5.4.2 to Release 5.4.3

#12 Updated by Ruben S. Montero almost 2 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF