Bug #484

VM Deployment Fails with NFS drivers

Added by Gian Uberto Lauri over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:02/14/2011
Priority:HighDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - AuthEstimated time:1.00 hour
Target version:-
Resolution:worksforme Pull request:
Affected Versions:

Description

Symptoms: oned creates the image and the context in /var/lib/one instead of the shared directory /srv/cloud/one/var/images/ after upgrading to 2.1-1

After seeing all my VM failing to boot, I started watching the log wandering under which absurd hypotesis (i.e. "The Vogon already demolished the planet" :) ) an

echo "/one/var/images/[vmid]/images/disk.0" | $SED -e 's/^[^:]*:\(.*\)$/\1/'

(core of arg_path called in tm_clone.sh) would change /srv/cloud/one/var/images/[vmid] into /var/lib/one/[vmid] when I saw a little

fix_paths

about in line 35... This function is defined in tm_common.sh and does that change :) !

Therefore i commented it and did the same to the

fix_dst_path

inline 41 of tm_context.sh and to the

fix_src_path

in line 34 of tm_delete.sh

Could it be that these instructions slipped in from the SSH driver ?

tm_clone.sh Magnifier - my fix (1.81 KB) Gian Uberto Lauri, 02/14/2011 07:35 PM

tm_context.sh Magnifier - my fix (1.83 KB) Gian Uberto Lauri, 02/14/2011 07:35 PM

tm_delete.sh Magnifier - my fix (1.44 KB) Gian Uberto Lauri, 02/14/2011 07:35 PM

Associated revisions

Revision 33f81172
Added by Sergio Semedi almost 3 years ago

remove trailing slashes VCENTER_DS_IMAGE_DIR (#484)

Revision 61ed4ee6
Added by Sergio Semedi almost 3 years ago

remove trailing slashes VCENTER_DS_IMAGE_DIR (#484)

(cherry picked from commit 33f81172c014a4d2db90a43aecbe80f2fce25df2)

History

#1 Updated by Javi Fontan over 9 years ago

Check if this explanation works for you http://dev.opennebula.org/issues/445#note-4

#2 Updated by Ruben S. Montero over 9 years ago

  • Target version changed from Release 2.0.1 to Release 2.2

#3 Updated by Javi Fontan over 9 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

#4 Updated by Gian Uberto Lauri over 9 years ago

I don't consider this closed. Had no time to follow it but is not closed, at least now.

#5 Updated by Javi Fontan over 9 years ago

  • Target version deleted (Release 2.2)

I'll leave it open then but without version as it is working for us in both 2.0.x and 2.2. Check the link provided before. Anyway "instead of the shared directory /srv/cloud/one/var/images/" tells me the problem is you are trying to use VM_DIR to set frontend's VM image dir to /srv/cloud/one/var and that is not its semantic.

#6 Updated by Gian Uberto Lauri over 9 years ago

O.K., I checked the #445 bug.

Mounting the NFS share as /var/lib/one is a bad solution, since you have to put the DB on the network disk, something that must be avoided.

I had the reported problem after updating to 2.1.

I will open a request for upgrade. Thank you.

Also available in: Atom PDF