Bug #4899

vnm_mad: Use absolute instead of relative path to require scripts in vnmmad-load.d directory

Added by Laurent Grawet almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:11/04/2016
Priority:HighDue date:
Assignee:-% Done:

0%

Category:Drivers - Network
Target version:Release 5.4
Resolution:fixed Pull request:https://github.com/OpenNebula/one/pull/139
Affected Versions:OpenNebula 5.2

Description

On hypervisor, scripts are located inside /var/tmp/one/vnm directory but executed from /var/lib/one directory and therefore, file require with relative path isn't working. The proposed solution is to use absolute path based one vnmmad.rb file location.

History

#1 Updated by Ruben S. Montero almost 4 years ago

  • Status changed from Pending to Closed
  • Target version changed from Release 5.2 to Release 5.4
  • Resolution set to fixed

Merged. Thanks!

Also available in: Atom PDF