Bug #4908

Live migration with fs_lvm fails

Added by Alex luft almost 4 years ago. Updated over 3 years ago.

Status:ClosedStart date:11/09/2016
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Documentation
Target version:Release 5.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.2

Description

Hi,

Seems to me that the /var/lib/one/remotes/tm/fs_lvm/premigrate does not create the vm folder in the datastore root and does not symlink the device.
So live migrate can't be done to a new host where the vm was not created on.
premigrate & postmigrate only do lvchange to the logical volume....

If I create the folder and symlinks manually, migration seems to work.

Wed Nov 9 14:49:29 2016 [Z0][VM][I]: New state is ACTIVE
Wed Nov 9 14:49:29 2016 [Z0][VM][I]: New LCM state is PROLOG
Wed Nov 9 14:52:59 2016 [Z0][VM][I]: New LCM state is BOOT
Wed Nov 9 14:52:59 2016 [Z0][VMM][I]: Generating deployment file: /var/lib/one/vms/7/deployment.0
Wed Nov 9 14:53:00 2016 [Z0][VMM][I]: Successfully execute transfer manager driver operation: tm_context.
Wed Nov 9 14:53:00 2016 [Z0][VMM][I]: ExitCode: 0
Wed Nov 9 14:53:00 2016 [Z0][VMM][I]: Successfully execute network driver operation: pre.
Wed Nov 9 14:53:02 2016 [Z0][VMM][I]: ExitCode: 0
Wed Nov 9 14:53:02 2016 [Z0][VMM][I]: Successfully execute virtualization driver operation: deploy.
Wed Nov 9 14:53:02 2016 [Z0][VMM][I]: post: Executed "sudo ovs-vsctl set Port one-7-0 tag=42".
Wed Nov 9 14:53:02 2016 [Z0][VMM][I]: ExitCode: 0
Wed Nov 9 14:53:02 2016 [Z0][VMM][I]: Successfully execute network driver operation: post.
Wed Nov 9 14:53:02 2016 [Z0][VM][I]: New LCM state is RUNNING
Wed Nov 9 15:44:59 2016 [Z0][VM][I]: New LCM state is MIGRATE
Wed Nov 9 15:45:00 2016 [Z0][VMM][I]: Successfully execute transfer manager driver operation: tm_premigrate.
Wed Nov 9 15:45:00 2016 [Z0][VMM][I]: ExitCode: 0
Wed Nov 9 15:45:00 2016 [Z0][VMM][I]: Successfully execute network driver operation: pre.
Wed Nov 9 15:45:01 2016 [Z0][VMM][I]: Command execution fail: cat << EOT | /var/tmp/one/vmm/kvm/migrate 'one-7' 'nebulahost001' 'nebulahost002' 7 nebulahost002
Wed Nov 9 15:45:01 2016 [Z0][VMM][E]: migrate: Command "virsh --connect qemu:///system migrate --live one-7 qemu+ssh://nebulahost001/system" failed: error: Cannot access storage file '/var/lib/one//datastores/104/7/disk.1' (as uid:9869, gid:9869): No such file or directory
Wed Nov 9 15:45:01 2016 [Z0][VMM][E]: Could not migrate one-7 to nebulahost001
Wed Nov 9 15:45:01 2016 [Z0][VMM][I]: ExitCode: 1
Wed Nov 9 15:45:01 2016 [Z0][VMM][I]: Successfully execute transfer manager driver operation: tm_failmigrate.
Wed Nov 9 15:45:01 2016 [Z0][VMM][I]: Failed to execute virtualization driver operation: migrate.
Wed Nov 9 15:45:01 2016 [Z0][VMM][E]: Error live migrating VM: Could not migrate one-7 to nebulahost001
Wed Nov 9 15:45:01 2016 [Z0][VM][I]: New LCM state is RUNNING
Wed Nov 9 15:45:01 2016 [Z0][LCM][I]: Fail to live migrate VM. Assuming that the VM is still RUNNING (will poll VM).

Related issues

Duplicated by Bug #4950: Change fs_lvm documentation to warn about the need of sha... Closed 12/15/2016

History

#1 Updated by Alex luft almost 4 years ago

Okay... probably not a bug :) I should mount the entire datastores folder via nfs or something.

#2 Updated by Ruben S. Montero almost 4 years ago

  • Category changed from Drivers - Network to Documentation
  • Status changed from Pending to New
  • Target version set to Release 5.4

Yes, the checkpoints, context disk and volatile disks are stored in file form in the system DS path. This needs to be better explained in the documentation. THANKS

#3 Updated by Ruben S. Montero over 3 years ago

  • Assignee set to Javi Fontan

#4 Updated by Javi Fontan over 3 years ago

  • Duplicated by Bug #4950: Change fs_lvm documentation to warn about the need of shared system datastore added

#5 Updated by Javi Fontan over 3 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Also available in: Atom PDF