Bug #4932

Debian 8 packaging: opennebula-node depends on libvirt-bin (transitional), should be libvirt-clients

Added by Johannes Brummer over 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:11/21/2016
Priority:LowDue date:
Assignee:Vlastimil Holer% Done:

0%

Category:Packaging
Target version:Release 5.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.2

Description

opennebula-node depends on libvirt-bin, which is a transitional package to libvirt-clients in Debian 8 (and libvirt-bin -package is missing from Debian 9)
Same change (transition to 2.x libvirt) happens on Ubuntu 16.10.

History

#1 Updated by Ruben S. Montero over 2 years ago

  • Assignee set to Javi Fontan
  • Target version set to Release 5.4

#2 Updated by Javi Fontan over 2 years ago

Thanks for the heads up. This will be changed for 5.4.

#3 Updated by Javi Fontan about 2 years ago

  • Assignee changed from Javi Fontan to Vlastimil Holer

#4 Updated by Vlastimil Holer about 2 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Hello,

we have changed the opennebula-node dependency for Debian 8 (and Ubuntu>16.04) from libvirt-bin to the libvirt-daemon-system. Dependency on libvirt-clients is already in libvirt-daemon-system and would be redundant (https://lists.debian.org/debian-user/2016/11/msg00529.html).

Thank you!
Vlastimil Holer

Also available in: Atom PDF