Bug #4935

Unable to add SSH public key with Update Configuration

Added by EOLE Team about 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:11/22/2016
Priority:NormalDue date:
Assignee:Abel Coronado% Done:

100%

Category:Sunstone
Target version:Release 5.4
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.2

Description

Hello,

During the advances hands-off tutorial at the OpenNebulaConf, we found a bug in the addition of SSH public key to a VM through Update Configuration.

Steps to reproduce:

  1. import Apps 45 Ubuntu 16.04 - KVM
  2. as oneadmin, without SSH public key set in its profile, instantiate Ubuntu 16.04 - KVM (it can be done with any user)
  3. the VM starts
  4. the VM context has SSH_PUBLIC_KEY = ""
  5. set an SSH public key in the user profile
  6. POWEROFF the VM
  7. in the Conf tab of the VM, click on Update Configuration
  8. click on Update

Now the VM context has SSH_PUBLIC_KEY = "$USER[SSH_PUBLIC_KEY]".

It should have SSH_PUBLIC_KEY = "ssh-rsa...".

I tested on 5.0 and did not find the problem.

History

#1 Updated by Ruben S. Montero about 3 years ago

  • Status changed from Pending to New
  • Target version set to Release 5.4

#2 Updated by novid Agha Hasani almost 3 years ago

It seems "Update Configuration" doesn't work anymore :(

I need change nic driver of VM to virtio..

I add MODEL = "virtio" to vm configuration but it doesn't update anything in database...

#3 Updated by Tino Vázquez over 2 years ago

  • Assignee set to Abel Coronado

#4 Updated by Abel Coronado over 2 years ago

  • % Done changed from 0 to 100

#5 Updated by Tino Vázquez over 2 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

This is the intended behaviour

Also available in: Atom PDF