Bug #4964

Attach a nic without selecting one make oned crash

Added by EOLE Team almost 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:01/02/2017
Priority:NormalDue date:
Assignee:Ruben S. Montero% Done:

0%

Category:Core & System
Target version:Release 5.4
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.2

Description

Hello,

We find a way to crash oned, it is reproductible:

  1. select a running VM
  2. select Network tab
  3. clic attach nic green button
  4. do not select any nic and clic Attach green button

The output is a red error message:

end of file reached

followed by another one:

Failed to open TCP connection to localhost:2633 (Connection refused - connect(2) for "localhost" port 2633)

It may be related to OpenNebula 5.2 segfault discussion on forum.

Regards.

History

#1 Updated by Ruben S. Montero almost 4 years ago

  • Category set to Core & System
  • Status changed from Pending to New
  • Assignee set to Ruben S. Montero
  • Target version set to Release 5.4

#2 Updated by Ruben S. Montero almost 4 years ago

  • Resolution set to worksforme

Sorry, I cannot reproduce this one in 5.2. I get:

Tue Jan  3 12:38:25 2017 [Z0][ReM][D]: Req:8000 UID:0 VirtualMachineAttachNic invoked , 0, "NIC="{}"" 
Tue Jan  3 12:38:25 2017 [Z0][DiM][E]: Wrong format or missing NIC attribute
Tue Jan  3 12:38:25 2017 [Z0][ReM][E]: Req:8000 UID:0 VirtualMachineAttachNic result FAILURE [VirtualMachineAttachNic] Wrong format or missing NIC attribute

Empty attach requests are checked was fixed here:

commit 9a440e558c64962e226af3758a7376b4384979af
Date:   Mon Apr 18 16:46:02 2016 +0200

Could it be a previous OpenNebula version 5.0.2 or something?

#3 Updated by EOLE Team almost 4 years ago

Ruben S. Montero wrote:

Sorry, I cannot reproduce this one in 5.2. I get:

[...]

Empty attach requests are checked was fixed here:
[...]

Could it be a previous OpenNebula version 5.0.2 or something?

My apologies, this is ONE 5.0.2, my 5.2 test infrastructure was reinstalled for something else :-/

You can close.

Sorry for the noise.

#4 Updated by Ruben S. Montero almost 4 years ago

  • Status changed from New to Closed

Great!

I prefer noise to bugs ;)

Also available in: Atom PDF