Bug #5018

Opennebula-sunstone does not upload images via web-interface.

Added by kvaps kvaps over 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:02/10/2017
Priority:NormalDue date:
Assignee:Abel Coronado% Done:

100%

Category:Sunstone
Target version:Release 5.4.1
Resolution:invalid Pull request:
Affected Versions:OpenNebula 5.2

Description

Hello I have two different installations of OpenNebula 5.2 with sunstone, and both have uploading images is not work via web insterface:

I got theese error messages in sunstone:

- Cannot contact server: is it running and reachable?
- It appears there was a server exception. Please check server's log.

I checked sunstone.log log, and see only this in each case:

"POST /upload_chunk HTTP/1.1" 200 - 0.0281
"POST /upload_chunk HTTP/1.1" 200 - 0.1321
"POST /upload_chunk HTTP/1.1" 200 - 0.0155
"POST /upload_chunk HTTP/1.1" 200 - 0.0205
"POST /upload_chunk HTTP/1.1" 200 - 0.0130
"POST /upload_chunk HTTP/1.1" 200 - 0.0158
"POST /upload HTTP/1.1" 500 - 30.0446

I checked oned.log logs, they are have no any messages about uploding image.

Also I checked temprary location: /var/tmp/ - it is exist, have right permissions and have available needed free size.

I watch about it:

When I start upload, my image appears here and start growing.
After it uploloaded by 100%, progress bar in sunstone freezed, and next inscription appears: Registering in OpenNebula.
After some time ~1 minute, I get the above errors.

I do not know where to dig further, I tried even strace, but it has not shown anything interesting.
I feel that there is no some action for finish registering image successful. That's just what, any ideas?

History

#1 Updated by kvaps kvaps over 3 years ago

Forgot to add, that after this error image is removed from temporary storage.

#2 Updated by Tino Vázquez over 3 years ago

  • Assignee set to Abel Coronado
  • Target version changed from Release 5.2.1 to Release 5.4.1

#3 Updated by Abel Coronado over 3 years ago

Hi,

I can't reproduce your problem.
I've upload a Debian image and I've added the image to the VM template without problems. Then, I've instantiated the template.

All ok.

Regards.

#4 Updated by Abel Coronado about 3 years ago

  • % Done changed from 0 to 100

#5 Updated by Tino Vázquez about 3 years ago

  • Status changed from Pending to Closed
  • Resolution set to invalid

Also available in: Atom PDF