Bug #5035

qcow2 snapshot should specify backing_fmt=qcow2 for apparmor to work properly

Added by Rolandas Naujikas over 3 years ago. Updated over 3 years ago.

Status:ClosedStart date:02/20/2017
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Drivers - VM
Target version:Release 5.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.14, OpenNebula 5.0, OpenNebula 5.2

Description

When using apparmor with kvm libvirt traverse all backing files with known format to create dynamic apparmor profile.
But in case it doesn't know format it stops traversing and doesn't add them.
Look https://bugs.launchpad.net/ubuntu/+source/libvirt/+bug/696318 for more details.
To reproduce we can create a VM from qcow2 datastore, then poweroff, then create disk snapshot, then start again - it fails.

We added -o backing_fmt=qcow2 to qcow2/clone, qcow2/snap_create and qcow2/snap_revert and it works properly.

Associated revisions

Revision 3a3f4a13
Added by Vlastimil Holer over 3 years ago

B #5035: Specify QCOW2 backing file formats (#341)

History

#1 Updated by Miguel Ángel Álvarez Cabrerizo over 3 years ago

  • Status changed from Pending to New
  • Target version set to Release 5.4

#2 Updated by Javi Fontan over 3 years ago

  • Assignee set to Vlastimil Holer

#3 Updated by Ruben S. Montero over 3 years ago

  • Assignee changed from Vlastimil Holer to Javi Fontan

#4 Updated by Vlastimil Holer over 3 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

We have fixed everything we could in the code.

There can be still problem with hot-attach of the nonpersistent disk due to the wrong AppArmor profile (https://bugzilla.redhat.com/show_bug.cgi?id=1361592).

Also available in: Atom PDF