Bug #5063

Snapshots of non-persistent images are not deleted on VM termination

Added by Christoph Pleger almost 3 years ago. Updated over 2 years ago.

Status:ClosedStart date:03/16/2017
Priority:NormalDue date:
Assignee:Vlastimil Holer% Done:

0%

Category:Drivers - Storage
Target version:Release 5.4.3
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.2

Description

Hello,

snapshots of non-persistent images are not deleted from disk on VM termination. As additionally they are not accessible anymore through the OpenNebula interface after VM termination, the only way to delete them from disk then is to do it manually, in most cases by calling /bin/rm .

Regards
Christoph

History

#1 Updated by Ruben S. Montero almost 3 years ago

What storage backend are you using? On VM termination the VM directory is removed, and so all the snapshots, this is for file based. Ceph also removes all the snapshots....

#2 Updated by Christoph Pleger almost 3 years ago

Snapshots are created in the image datastore, not in the system datastore, so removing the VM directory does not remove snapshots.

I am using fs for datastore management and shared for transfer management.

#3 Updated by Ruben S. Montero over 2 years ago

  • Category set to Drivers - Storage
  • Assignee set to Vlastimil Holer
  • Target version set to Release 5.4.3

#4 Updated by Vlastimil Holer over 2 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

Hi Christoph,

I'm trying to reproduce the problem with the latest ONE 5.4 and it's behaving as Ruben describes, the snapshots for non-persistent images are created in the VM directory inside the system datastore. It looks like some deployment misconfiguration if you see the snapshots for non-persistent images inside the image datastore.

If it still happens for you, please provide some more details. You can send them as a private e-mail if you prefer (). For example:

1. XML description of your datastores configuration (onedatastore list --xml)
2. XML description of some affected VM (for VM ID 123, e.g. onevm show --xml 123)
3. Parts of the /etc/one/oned.conf related to the datastores (TM_MAD_CONF)

For now, I'm closing this bug.

Best regards,
Vlastimil Holer

Also available in: Atom PDF