Bug #5199

ON reports successful monitoring of KVM-HV's, although it fails due to ulimit being hit

Added by Christian Wehrlin over 2 years ago. Updated about 2 years ago.

Status:PendingStart date:06/22/2017
Priority:NormalDue date:
Assignee:Vlastimil Holer% Done:

0%

Category:Drivers - VM
Target version:Release 5.4.4
Resolution: Pull request:
Affected Versions:OpenNebula 5.2

Description

If you have a KVM-Hypervisor in your setup, that has reached, or is about to reach the ulimit, OpenNebula will probably fail trying to do the run_probes, but instead of throwing an error, it will simply report that the machine was successfully monitored.

While trying to open a remote shell manually, you'll get the Error:

Resource temporarily unavailable

But in the oned.log, all you just see is basically something like

Wed Jun 21 12:36:54 2017 [Z0][InM][D]: Host node18.blafasel (23) successfully monitored.

Of course, the quick fix is to increase the ulimits on the Hypervisor to more suitable values, nonetheless, it should be expected for OpenNebula to report an issue when trying to remote-execute run_probes

History

#1 Updated by Ruben S. Montero about 2 years ago

  • Category set to Drivers - VM
  • Assignee set to Vlastimil Holer
  • Target version set to Release 5.4.3

#2 Updated by Vlastimil Holer about 2 years ago

Hello Christian,

I have tried to reproduce the problem with ONE 5.4, but couldn't. Do you have any chance to confirm it doesn't happen for you on 5.4?

What kind of resources are you limiting?

Best regards,
Vlastimil Holer

#3 Updated by Tino Vázquez about 2 years ago

  • Target version changed from Release 5.4.3 to Release 5.4.4

Also available in: Atom PDF