Bug #5209

disk image resize on attach should be in MB

Added by Anton Todorov about 4 years ago. Updated almost 4 years ago.

Status:ClosedStart date:06/30/2017
Priority:NormalDue date:
Assignee:Abel Coronado% Done:


Target version:Release 5.4
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.2



While testing our addon I've hit the following issue.

In Sunstone, when I use the advanced options in the attach dialog to order different disk size it works with values in GB instead of MB.

How to reproduce:
Attach a disk to a vm with different size in MB (for example 10240 for 10 GB)

Observed behavior:
The resulting image on the storage is with size ~10TB

Expected behavior:
Image with size 10GB

I am not sure is it an Sunstone issue only so please set the proper category.

Best Regards,
Anton Todorov

Associated revisions

Revision c0be5656
Added by Abel Coronado almost 4 years ago

B #5209 Solved bug on attach disk VM

Revision 97e07139
Added by Javi Fontan almost 4 years ago

Merge pull request #384 from abelCoronado93/bug-5209

B #5209 Solved bug on attach disk VM


#1 Updated by Abel Coronado almost 4 years ago

  • Category set to Sunstone
  • Assignee set to Abel Coronado
  • Target version set to Release 5.4
  • % Done changed from 0 to 100
  • Affected Versions OpenNebula 5.2 added

#2 Updated by Javi Fontan almost 4 years ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Fixed in master, also for templae. Now it's always MB.

Also available in: Atom PDF