Bug #5300

Disk size is not monitored (qcow2)

Added by Kristian Feldsam 3 months ago. Updated about 1 month ago.

Status:ClosedStart date:08/02/2017
Priority:NormalDue date:
Assignee:Vlastimil Holer% Done:

0%

Category:Drivers - Monitor
Target version:Release 5.4.1
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.4

Description

After upgrade to 5.4, real disk size is not monitored. In sunstone for ex. I see only -/10GB and not 2.3GB/10GB

In VM xml is missing DISK_SIZE section like was in 5.2

<DISK_SIZE>
      <ID><![CDATA[0]]></ID>
      <SIZE><![CDATA[10956]]></SIZE>
</DISK_SIZE>

Associated revisions

Revision 6faed83d
Added by Ruben S. Montero about 1 month ago

B #5300 Write disk monitor information

Revision 3f7b20ef
Added by Ruben S. Montero about 1 month ago

B #5300: Counter is stored per datastore

Revision 0b765130
Added by Ruben S. Montero about 1 month ago

B #5300: Update monitor information on VMs

Revision 55317502
Added by Ruben S. Montero about 1 month ago

B #5300 Write disk monitor information

(cherry picked from commit 6faed83d43d05a11927d8bf888c4c8b8fc4dc6ff)

Revision 7544db12
Added by Ruben S. Montero about 1 month ago

B #5300: Counter is stored per datastore

(cherry picked from commit 3f7b20efcc414cdd907c987241f9f722edc4c473)

Revision 88401379
Added by Ruben S. Montero about 1 month ago

B #5300: Update monitor information on VMs

(cherry picked from commit 0b76513078788d10af98e42c1eee18bd9973ce2e)

History

#1 Updated by Ruben S. Montero 3 months ago

  • Assignee set to Javi Fontan
  • Target version set to Release 5.4.1

#2 Updated by Javi Fontan 2 months ago

  • Assignee changed from Javi Fontan to Vlastimil Holer

#3 Updated by Vlastimil Holer 2 months ago

  • Assignee changed from Vlastimil Holer to Ruben S. Montero

The problem is, that the VM metrics generated by the datastore probes aren't stored in the database, but only left in the memory. On 5.4 (with disabled caching), such metrics are unfortunately lost between the monitoring tasks.

Here are the examples of a VM monitored by 2 different probes, see the update_db parameter. KVM monitoring doesn't see any metrics from previous DS monitoring.

DS

Wed Aug 16 20:30:12 2017 [Z0][InM][D]: Monitoring datastore system (0)
Wed Aug 16 20:30:12 2017 [Z0][VMM][D]: VH: VirtalMachineManagerDriver::process_poll with update_db=0
Wed Aug 16 20:30:12 2017 [Z0][VMM][D]: VM 10 debug before update:

Wed Aug 16 20:30:12 2017 [Z0][VMM][D]: VM 10 debug after update:
DISK_SIZE=ID=0,SIZE=481
DISK_SIZE=ID=1,SIZE=1

Wed Aug 16 20:30:12 2017 [Z0][VMM][D]: VM 10 successfully monitored: DISK_SIZE=[ID=0,SIZE=481] DISK_SIZE=[ID=1,SIZE=1] 
Wed Aug 16 20:30:12 2017 [Z0][ImM][D]: Datastore system (0) successfully monitored.

KVM

Wed Aug 16 20:30:27 2017 [Z0][InM][D]: Monitoring host centos7-kvm-nfs-6bb5b-2.test (1)
Wed Aug 16 20:30:30 2017 [Z0][InM][D]: Host centos7-kvm-nfs-6bb5b-2.test (1) successfully monitored.
Wed Aug 16 20:30:30 2017 [Z0][VMM][D]: VH: VirtalMachineManagerDriver::process_poll with update_db=1
Wed Aug 16 20:30:30 2017 [Z0][VMM][D]: VM 10 debug before update:

Wed Aug 16 20:30:30 2017 [Z0][VMM][D]: VM 10 debug after update:
CPU=98.02
DISKRDBYTES=39140352
DISKRDIOPS=2388
DISKWRBYTES=0
DISKWRIOPS=0
MEMORY=524288
NETRX=0
NETTX=0
STATE=a

Wed Aug 16 20:30:30 2017 [Z0][VMM][D]: VM 10 successfully monitored: STATE=a CPU=98.02 MEMORY=524288 NETRX=0 NETTX=0 DISKRDBYTES=39140352 DISKWRBYTES=0 DISKRDIOPS=2388 DISKWRIOPS=0

This part in the core
https://github.com/OpenNebula/one/blob/37dc649fd73d46616a71b8dcb6ebc49310d627a2/src/vmm/VirtualMachineManagerDriver.cc#L728-L738
needs to be changed, so that the vmpool->update_monitoring is done even if update_db isn't requested. Looks like the update_db parameter is now obsolete.

Reassigning to Ruben to propose the changes.

#4 Updated by Ruben S. Montero about 1 month ago

  • Assignee changed from Ruben S. Montero to Vlastimil Holer

#5 Updated by Ruben S. Montero about 1 month ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Also available in: Atom PDF