Bug #5301

Wrong error msg when disk-saveas without name

Added by Anton Todorov 3 months ago. Updated about 1 month ago.

Status:ClosedStart date:08/03/2017
Priority:NormalDue date:
Assignee:Juan Jose Montiel Cano% Done:

100%

Category:Core & System
Target version:Release 5.4.1
Resolution:fixed Pull request:
Affected Versions:OpenNebula 5.4

Description

How to reproduce in sunstone:

1. Open VM Storage tab
2. Click on "Saveas"
3. Click on "Save as" without providing "New image name"

Result:
An error message pop-up with the containing the text
[one.vm.disksaveas] Error allocating a new virtual machine. Invalid NAME, it cannot be empty

Expected:
My asumption for text
[one.vm.disksaveas] Error creating a new image. Invalid NAME, it cannot be empty

It is cosmetic, as only the error message is wrong, the reason is OK.

Looks like it is in the core, please fix the Category if I am wrong.

Best Regards,
Anton Todorov


Related issues

Related to Bug #5321: Wrong message when doing a disk save as Closed 08/24/2017

Associated revisions

Revision cdd5bc84
Added by Juan Jose Montiel Cano about 1 month ago

B #5301 Changed Error msg when disk-saveas without name (#445)

Revision 6a96423c
Added by Juan Jose Montiel Cano about 1 month ago

B #5301 Changed Error msg when disk-saveas without name (#445)

(cherry picked from commit cdd5bc848ce1dec6b1efa2848067c7c82ae3400f)

History

#1 Updated by Ruben S. Montero 3 months ago

  • Target version set to Release 5.4.1

#2 Updated by Juan Jose Montiel Cano about 1 month ago

  • Assignee set to Juan Jose Montiel Cano
  • % Done changed from 0 to 100

#3 Updated by Juan Jose Montiel Cano about 1 month ago

  • Related to Bug #5321: Wrong message when doing a disk save as added

#4 Updated by Ruben S. Montero about 1 month ago

  • Status changed from Pending to Closed
  • Resolution set to fixed

Also available in: Atom PDF