Bug #5413

vCenter VM can have different NIC MAC than requested

Added by Vlastimil Holer over 2 years ago. Updated over 2 years ago.

Status:ClosedStart date:09/27/2017
Priority:NormalDue date:
Assignee:Sergio Semedi% Done:

0%

Category:vCenter
Target version:Release 5.4.3
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.4

Description

It can happen, maybe due to the MAC address collision detection in the vCenter, that VM assigned NIC MAC address is different, then requested.

Example: Have VNET w/ IPv4 AR containing IP 10.0.1.236 (MAC 02:00:0a:00:01:ec). If VM is deployed with this NIC MAC/IP, some superior power can decide there is a problem to assign this particular MAC address and chooses different one. In my case 00:50:56:a3:dd:bd. This wrong MAC can be seen:
1. inside the VM
2. in the vCenter
but not in the OpenNebula, there is still the originally requested MAC/IP.

If I hot-attach NIC with problematic MAC/IP, it works correctly. Looks like the problem is only when used with newly deployed VM.

Also, there is problem with detaching such NIC, becase detach works with MAC addresses and in this situation, they are different in VM/vCenter and ONE. So, detach proceeds in the OpenNebula, but NIC is still attached.

Checked on the vOneCloud 3.0.2/ONE 5.4.1.

History

#1 Updated by Vlastimil Holer over 2 years ago

  • Subject changed from vCenter VM can have different NIC MACs than requested to vCenter VM can have different NIC MAC than requested

#2 Updated by Ruben S. Montero over 2 years ago

  • Category set to vCenter
  • Target version set to Release 5.4.3

#3 Updated by Tino Vázquez over 2 years ago

  • Status changed from Pending to New
  • Assignee set to Sergio Semedi

#4 Updated by Sergio Semedi over 2 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Also available in: Atom PDF