Bug #5442

FILES_DS template variable disappears if update the configuration.

Added by Sergio Milanese about 3 years ago. Updated about 3 years ago.

Status:ClosedStart date:10/06/2017
Priority:HighDue date:
Assignee:Abel Coronado% Done:

0%

Category:Sunstone
Target version:Release 5.4.3
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.4

Description

Hello,

in Sunstone, if you update configuration, for example, you change the variable SET_HOSTNAME, the variable containing the FILES_DS contextualization scripts disappears.
This makes it impossible for the next boot to run these scripts because the contextual cdrom only has context.sh.
You can also resolve this problem by adding the Sunstone option to also select additional contextualization files that are added later, for example in the files section in this time that only has the execution order (INIT_SCRIPTS variable).
Thank you

Sergio


Related issues

Related to Bug #5484: Custom vars in CONTEXT shouldn't let objects be created Closed 10/20/2017

History

#1 Updated by Ruben S. Montero about 3 years ago

  • Category set to Sunstone
  • Assignee set to Abel Coronado
  • Target version set to Release 5.4.3

#2 Updated by Ruben S. Montero about 3 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

It seems that we cannot reproduce in the last version 5.4.2. We'll reopen if fixed. As a side note we found a related issue.

#3 Updated by Ruben S. Montero about 3 years ago

  • Related to Bug #5484: Custom vars in CONTEXT shouldn't let objects be created added

Also available in: Atom PDF