Bug #5455

oneacct gives ruby error

Added by Stefan Kooman about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:10/13/2017
Priority:NormalDue date:
Assignee:Sergio Semedi% Done:

0%

Category:CLI
Target version:Release 5.4.3
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 5.4, OpenNebula 5.4.1, OpenNebula 5.4.2

Description

oneacct -u 0 --start 08/03/2017 --end 10/05/2017 --split

Showing active history records from 2017-03-08 00:00:00 +0100 to 2017-05-11 00:00:00 +0200

  1. User 0

    VID HOSTNAME REAS START_TIME END_TIME MEMORY CPU
    7 redacted none 11/27 11:14:41 - 512M 1

    VID HOSTNAME REAS START_TIME END_TIME MEMORY CPU NET_RX NET_TX
    /usr/lib/one/ruby/cli/cli_helper.rb:301:in `block (2 levels) in data_array': undefined method `call' for nil:NilClass (NoMethodError)
    Did you mean? caller
    from /usr/lib/one/ruby/cli/cli_helper.rb:300:in `collect'
    from /usr/lib/one/ruby/cli/cli_helper.rb:300:in `block in data_array'
    from /usr/lib/one/ruby/cli/cli_helper.rb:299:in `collect'
    from /usr/lib/one/ruby/cli/cli_helper.rb:299:in `data_array'
    from /usr/lib/one/ruby/cli/cli_helper.rb:268:in `print_data'
    from /usr/lib/one/ruby/cli/cli_helper.rb:263:in `print_table'
    from /usr/lib/one/ruby/cli/cli_helper.rb:229:in `show'
    from /usr/bin/oneacct:143:in `block (4 levels) in <main>'
    from /usr/bin/oneacct:141:in `each'
    from /usr/bin/oneacct:141:in `block (3 levels) in <main>'
    from /usr/bin/oneacct:136:in `each'
    from /usr/bin/oneacct:136:in `block (2 levels) in <main>'
    from /usr/lib/one/ruby/cli/command_parser.rb:449:in `run'
    from /usr/lib/one/ruby/cli/command_parser.rb:76:in `initialize'
    from /usr/bin/oneacct:35:in `new'
    from /usr/bin/oneacct:35:in `<main>'

History

#1 Updated by Stefan Kooman about 2 years ago

I can reproduce this on ONE 5.4.0 (also ONE 5.2.1). Environment: Ubuntu Xenial 16.04

#2 Updated by Ruben S. Montero about 2 years ago

  • Category set to CLI
  • Assignee set to Sergio Semedi
  • Target version set to Release 5.4.3
  • Affected Versions OpenNebula 5.4, OpenNebula 5.4.2 added

#3 Updated by Sergio Semedi about 2 years ago

Stefan Kooman wrote:

I can reproduce this on ONE 5.4.0 (also ONE 5.2.1). Environment: Ubuntu Xenial 16.04

Hi,

Im afraid that im not able to reproduce this issue on my opennebula installation.
would you care to post here the result of: $ oneacct -x -u 0 --start 08/03/2017 --end 10/05/2017 --split

Send me the output via email () if u prefer to share it privately.

#4 Updated by Ruben S. Montero about 2 years ago

  • Status changed from Pending to Closed
  • Resolution set to worksforme

If the error persists we can reopen the ticket

#5 Updated by Stefan Kooman about 2 years ago

-x (xml) and -j (json) output works fine. So it's something having trouble parsing the output it gets.

#6 Updated by Sergio Semedi about 2 years ago

Yes but the problem is that the command works perfectly for me so it would be nice if u could share your output, after that we will track any clue to reproduce the problem and find the solution.

Also available in: Atom PDF