Bug #561

ArgumentError when executing host_error.rb

Added by Giovanni Toraldo over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:04/07/2011
Priority:NormalDue date:
Assignee:Tino Vázquez% Done:

0%

Category:Core & System
Target version:Release 3.0
Resolution:duplicate Pull request:
Affected Versions:

Description

$ /usr/share/one/hooks/host_error.rb 5 -r n
/usr/lib/one/ruby/OpenNebula/XMLUtils.rb:116:in `each': wrong number of arguments (1 for 0) (ArgumentError)
from /usr/lib/one/ruby/OpenNebula/XMLUtils.rb:116:in `retrieve_elements'
from /usr/share/one/hooks/host_error.rb:72

Debian Lenny host
oneadmin@nebula01:~$ dpkg -l|grep ruby
ii libruby1.8 1.8.7.302-2~bpo50+1 Libraries necessary to run Ruby 1.8
ii libsqlite3-ruby 1.2.2-1 SQLite3 interface for Ruby
ii libsqlite3-ruby1.8 1.2.2-1 SQLite3 interface for Ruby 1.8
ii ruby 4.2 An interpreter of object-oriented scripting
ii ruby1.8 1.8.7.302-2~bpo50+1 Interpreter of object-oriented scripting lan
ii ruby1.8-dev 1.8.7.302-2~bpo50+1 Header files for compiling extension modules
ii rubygems 1.3.4-1~bpo50+1 package management framework for Ruby librar
ii rubygems1.8 1.3.4-1~bpo50+1 package management framework for Ruby librar

Associated revisions

Revision a0a2a034
Added by Sergio Semedi almost 3 years ago

B #5531: vcenter images now are imported properly (#561)

  • B #5531: OpenNebula does not duplicate template/VM images
  • B #5531: onevcenter images works as expected
  • B #5531: vcenter imported images adquire proper names

Revision 97d4a54a
Added by Sergio Semedi almost 3 years ago

B #5531: vcenter images now are imported properly (#561)

  • B #5531: OpenNebula does not duplicate template/VM images
  • B #5531: onevcenter images works as expected
  • B #5531: vcenter imported images adquire proper names

(cherry picked from commit a0a2a034d7920f2261d9bc5208f5db29a28af7de)

History

#1 Updated by Giovanni Toraldo over 9 years ago

Changed line 116 in XMLUtils.rb from:

@xml.each(filter.to_s) { |e|  ids_array << e.text }

to:
@xml.elements.each(filter) { |e| ids_array << e.text }

#2 Updated by Ruben S. Montero over 9 years ago

  • Assignee set to Tino Vázquez
  • Target version set to Release 3.0

#3 Updated by Tino Vázquez over 9 years ago

  • Resolution set to duplicate

Duplicate of 597

#4 Updated by Tino Vázquez over 9 years ago

  • Status changed from New to Closed

Also available in: Atom PDF