Bug #590

Image registration time in Sunstone not corresponding to CLI times

Added by Hector Sanjuan over 9 years ago. Updated over 9 years ago.

Status:ClosedStart date:04/26/2011
Priority:NormalDue date:
Assignee:Hector Sanjuan% Done:

100%

Category:Sunstone
Target version:Release 3.0
Resolution:fixed Pull request:
Affected Versions:

Description

Reported by user on IRC. Maybe an issue with the time conversions:

8:28:32 PM sneumann: Hm, sunstone is getting some dates wrong:
8:28:37 PM sneumann: oneimage list says
8:28:39 PM sneumann: 16 oneadmin ubuntulucid OS Apr 14, 2011 18:27 Yes No rdy 0
8:28:44 PM sneumann: sunstone shows
8:29:00 PM sneumann: 16 oneadmin ubuntulucid OS 20:27:44 03/14/2011 yes no READY 0
8:29:50 PM sneumann: Where 03/14/2011 != Apr 14, 2011 , both oneimage, oned and sunstone are running on the same host
8:29:59 PM sneumann: That's more than daylight saving
[12:18:54 PM] Javi Fontan: 8:43:40 PM sneumann: jfontan: could that be an off-by-one in the month conversion ?

0001-Bug-590-Corrected-pretty_time-function-to-show-the-c.patch Magnifier (964 Bytes) Hector Sanjuan, 05/03/2011 01:10 PM


Related issues

Duplicated by Bug #658: Sunstone incorrectly displays dates Closed 05/23/2011

Associated revisions

Revision 2c0652ed
Added by Hector Sanjuan over 9 years ago

Bug #590: Corrected pretty_time function to show the correct month.

History

#1 Updated by Hector Sanjuan over 9 years ago

Added patch. Caused by getMonth() function returning an integer between 0 (january) and 11(dec).

#2 Updated by Daniel Molina over 9 years ago

  • Status changed from New to Closed

Also available in: Atom PDF