Bug #674

Debian init.d script fails to start oned

Added by Vivien Bernet-Rollande over 8 years ago. Updated over 8 years ago.

Status:ClosedStart date:06/10/2011
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Core & System
Target version:Release 3.0
Resolution:fixed Pull request:
Affected Versions:

Description

I had a problem lately. On boot, oned was not started. I had to log in as oneadmin to start it. The reason was that the ONE_AUTH variable did not exist.

My setup is as follow :
- oneadmin has it's home in /var/lib/one
- /var/lib/one/.profile exports ONE_AUTH to the right value

The startup script does a "su oneadmin -s /bin/sh -c 'one start'".

The problem is that this will not load the .profile, and oned fails to start, complaining that :

You should have ONE_AUTH set the first time you start
OpenNebula as it is used to set the credentials for
the administrator user.

The small patch attached does a "su - oneadmin -s /bin/bash -c 'one start'"

This fixes the problem for me. However, I'm not sure it's the most elegant way to fix the problem, so I'm open to suggestions.

one_debian_init.patch Magnifier - load oneadmin's .profile before starting oned (375 Bytes) Vivien Bernet-Rollande, 06/10/2011 01:47 PM


Related issues

Related to Bug #760: ONE_AUTH not defined when using init.d script Closed 08/02/2011

History

#1 Updated by Ruben S. Montero over 8 years ago

  • Status changed from New to Assigned
  • Assignee changed from Ruben S. Montero to Jaime Melis
  • Target version set to Release 3.0

#2 Updated by Jaime Melis over 8 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

OpenNebula package now creates a random password before starting

Also available in: Atom PDF