Feature #70

one{vnet,vm,host} list should be available as API calls

Added by Redmine Admin about 11 years ago. Updated about 11 years ago.

Status:ClosedStart date:
Priority:HighDue date:
Assignee:Javi Fontan% Done:

0%

Category:Client API & Library
Target version:Release 1.4
Resolution:duplicate Pull request:

Description

It would be very helpful if the "one{vnet,vm,host} list" commands could be available in the API.

What is the rationale for having those tools directly look in the sqlite database? Historical reasons, perhaps?

History

#1 Updated by Ruben S. Montero about 11 years ago

Yes there are some reasons although not historical ;). Take a look to #33

#2 Updated by Redmine Admin about 11 years ago

Ah, thanks for the reference. I've commented on that bug now.

#3 Updated by Ruben S. Montero about 11 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

Closing this one, I'll mark as duplicate of #33. I've reopen #33 to re-think this issue and discuss implementation alternatives.

Also available in: Atom PDF