Bug #759

Template Parsing

Added by Keith Horrocks over 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:08/01/2011
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Core & System
Target version:Release 3.2
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.0

Description

Creating a machine template with certain characters (angle brackets are the only one's I've tested) causes things to mess up. In version 2.2 this meant that new machines could not be created until the 'damaged' machines were deleted. Version 3.0beta seems to do better (new machines can be created), but it still seems to not be able to refresh the templates in Sunstone (constant loading swirl) and a `onetemplate list` results in

/usr/lib/one/ruby/OpenNebula/XMLUtils.rb:252:in `to_hash': undefined method `document' for nil:NilClass (NoMethodError)
from /usr/lib/one/ruby/cli/one_helper.rb:95:in `list_pool'
from /usr/bin/onetemplate:173
from /usr/lib/one/ruby/cli/command_parser.rb:172:in `call'
from /usr/lib/one/ruby/cli/command_parser.rb:172:in `run'
from /usr/lib/one/ruby/cli/command_parser.rb:79:in `initialize'
from /usr/bin/onetemplate:33:in `new'
from /usr/bin/onetemplate:33

This can be reproduced by using 'NAME = <name>' inside a template.

Associated revisions

Revision f0d8ac78
Added by Carlos Martín about 8 years ago

Bug #759: Check if XML is valid before it is stored in the DB.

History

#1 Updated by Carlos Martín over 8 years ago

  • Category set to Core & System

Hi,

This is caused because internally all templates are stored in XML.
We should improve the parser to detect these invalid symbols.

Thanks for the feedback!

#2 Updated by Tino Vázquez over 8 years ago

  • Affected Versions OpenNebula 3.0 added

#3 Updated by Ruben S. Montero over 8 years ago

  • Target version set to Release 3.4

#4 Updated by Ruben S. Montero about 8 years ago

  • Target version changed from Release 3.4 to Release 3.2

#5 Updated by Ruben S. Montero about 8 years ago

  • translation missing: en.field_story_points set to 0

#6 Updated by Ruben S. Montero about 8 years ago

  • Status changed from New to Assigned
  • Assignee set to Carlos Martín

#7 Updated by Ruben S. Montero about 8 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF