Feature #914

Provide simple install, dependency and configuration check

Added by Steffen Neumann almost 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:10/13/2011
Priority:NormalDue date:
Assignee:Javi Fontan% Done:

0%

Category:Core & System
Target version:Release 3.4 - S0
Resolution:fixed Pull request:

Description

Hi,

While upgrading to 3.0 I found that it is difficult to comply with all dependencies
required by ONE. Agreed, I could read the installation and migration pages
in the documentation very closely, and check manually and do checkmarks on paper.

Since I didn't have libsqlite3-ruby installed (duh!) my onedb upgrade failed,
but with an error message "Database schema does not look to be created by OpenNebula: table user_pool is missing or empty."
which is highly misleading.

A simple script that checks for correct installation of ONE and it's dependencies would be very helpful,
checking e.g. all required gems, maybe even reading oned.conf to see whether sqlite or mysql is needed, etc.
It could do a syntax check on oned.conf, to see whether it has the right format,
it could onedb version to check whether a migration is required. If there are onevm hosts, it could check
whether it can do passwordless ssh etc.

The script could emit INFO (including version information of found gems, etc.),
WARNING (if sqlite3 is not found, which could be OK in case mysql is used)
and stop on ERROR messages. Via command lines it could perform only a subset of the checks.

Answers on the mailing list could have the output of onecheck as a precondition ;-)

Yours,
Steffen


Related issues

Blocked by Feature #949: Extend install_gems.sh to just check for gems Closed 10/31/2011

Associated revisions

Revision 09aa1a7d
Added by Javi Fontan over 8 years ago

features #914, #949: --check and faster install_gems

  • added --check options that detects the ruby libraries not installed
  • only install gems not found
  • execute 'gem' only once when possible

Revision 16a1b24b
Added by Javi Fontan over 8 years ago

feature #914: update rubygems if version older than 1.3.6

History

#1 Updated by Ruben S. Montero almost 9 years ago

  • Target version set to Release 3.4

#2 Updated by Ruben S. Montero over 8 years ago

  • Target version changed from Release 3.4 to Release 3.2 - Beta1

#3 Updated by Ruben S. Montero over 8 years ago

  • Target version changed from Release 3.2 - Beta1 to Release 3.2

#4 Updated by Ruben S. Montero over 8 years ago

  • Category set to Core & System
  • Status changed from New to Assigned
  • Assignee set to Javi Fontan

#5 Updated by Javi Fontan over 8 years ago

  • Target version changed from Release 3.2 to Release 3.4

#6 Updated by Ruben S. Montero over 8 years ago

  • Target version changed from Release 3.4 to Release 3.4 - S0

#7 Updated by Javi Fontan over 8 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Also available in: Atom PDF