Bug #1230

oneacctd crash

Added by olivier sallou almost 8 years ago. Updated over 7 years ago.

Status:ClosedStart date:04/12/2012
Priority:NormalDue date:
Assignee:Carlos Martín% Done:

0%

Category:Core & System
Target version:Release 3.6
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.2

Description

I faced recently (not the first time) a crash of oneacctd process.

Here is the log:

/usr/lib/one/ruby/acct/accounting.rb:113:in `update_history': undefined method `[]' for nil:NilClass (NoMethodError)
from /usr/lib/one/ruby/acct/accounting.rb:127:in `insert_vm'
from /usr/lib/one/ruby/acct/accounting.rb:44:in `insert'
from /usr/lib/one/ruby/acct/accounting.rb:34:in `each'
from /usr/lib/one/ruby/acct/accounting.rb:34:in `insert'
from /usr/lib/one/ruby/acct/acctd.rb:77:in `update'
from /usr/lib/one/ruby/acct/acctd.rb:59:in `each'
from /usr/lib/one/ruby/acct/acctd.rb:59:in `update'
from /usr/lib/one/ruby/acct/acctd.rb:57:in `each'
from /usr/lib/one/ruby/acct/acctd.rb:57:in `update'
from /usr/lib/one/ruby/acct/acctd.rb:129
from /usr/lib/one/ruby/acct/acctd.rb:124:in `loop'
from /usr/lib/one/ruby/acct/acctd.rb:124

I cannot reproduce it, but I am creating/deleting VM a lot (in short periods of time) for testing.

History

#1 Updated by Ruben S. Montero over 7 years ago

  • Category set to Core & System
  • Status changed from New to Assigned
  • Assignee set to Carlos Martín
  • Target version set to Release 3.6
  • Resolution set to fixed

We've integrated the whole accounting process in OpenNebula core to fix this kind of issues. I am closing this one

#2 Updated by Ruben S. Montero over 7 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF