Bug #1266

possible bug - opennebula 3.4 - WSS - User-based configuration

Added by João Pagaime over 7 years ago. Updated over 7 years ago.

Status:ClosedStart date:05/04/2012
Priority:NormalDue date:
Assignee:Hector Sanjuan% Done:

0%

Category:Sunstone
Target version:Release 3.6
Resolution:worksforme Pull request:
Affected Versions:OpenNebula 3.4

Description

Hello developers,

don't know if it was a particular problem of our test installation, but it seems that Sunstone "User-based configuration " was not taken from sunstone-server.conf file as documented [1]

one thing was for sure:

- Sunstone launched websockify without secure VNC settings (as configured on sunstone-server.conf)

- Firefox tried to connect to the websocket through WSS (didn't work though)

after setting Dashboard -> Configuration -> Secure websockets connection to "No" it started to work normally

didn't find it easy to track down this issue. Only after comparing the URI on opennebula 3.2 and 3.4, the first "ws:" and the second "wss:", some light came to the problem

additional information:

- OS: CentOS release 6.2 (Final)

- Opennebula: CentOS-6.0-opennebula-3.4.0-1.x86_64.rpm

cheers,
João

[1]
http://opennebula.org/documentation:rel3.4:sunstone -> "User-based configuration"

History

#1 Updated by Hector Sanjuan over 7 years ago

  • Category set to Sunstone
  • Assignee set to Hector Sanjuan

Hello,

can you paste or attach your sunstone-server.conf?

#2 Updated by Ruben S. Montero over 7 years ago

  • Target version set to Release 3.6

#3 Updated by Ruben S. Montero over 7 years ago

  • Status changed from New to Assigned

#4 Updated by Hector Sanjuan over 7 years ago

  • Resolution set to worksforme

I have tried and seems to work for me.

If the WSS=yes|no is in user template then this value is used. Otherwise the configuration value is used. Maybe the user had it wrongly set?

#5 Updated by Ruben S. Montero over 7 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF