Bug #1274

Improve error messages for Sunstone login

Added by Ruben S. Montero about 9 years ago. Updated over 8 years ago.

Status:ClosedStart date:05/11/2012
Priority:NormalDue date:
Assignee:Hector Sanjuan% Done:

100%

Category:Sunstone
Target version:Release 3.8
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.4

Description

This has been reported by João Pagaime in the mailing list

In case of a wrong (LDAP) password, Sunstone gives the following error message:
"OpenNebula is not running or there was a server exception. Please check the
server logs."

This message is a bit confusing for LDAP uses. I suggest another error
messagem like:
"Authenticaton failure: wrong username, password or OpenNebula is not
running or there was a server exception".
Of course a better error messagem would be: ""Authenticaton failure: (real
reason)"

Associated revisions

Revision 0e8bd80f
Added by Hector Sanjuan over 8 years ago

Bug #1274: Fix internal server error when wrong auth with opennebula auth

It was caused by an attempt of logging when no logger had been passed to CloudAuth.

Affected Sunstone only.
(cherry picked from commit 97b62f8857a9064eb534041c09b742779cf79dfd)

History

#1 Updated by Ruben S. Montero over 8 years ago

  • Status changed from New to Assigned

#2 Updated by Hector Sanjuan over 8 years ago

  • % Done changed from 0 to 100
  • Resolution set to fixed

#3 Updated by Ruben S. Montero over 8 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF