Bug #1331

Sunstore : weird SQL error

Added by jordan pittier about 8 years ago. Updated about 8 years ago.

Status:ClosedStart date:07/04/2012
Priority:NormalDue date:
Assignee:Hector Sanjuan% Done:

100%

Category:Sunstone
Target version:Release 3.6
Resolution:fixed Pull request:
Affected Versions:OpenNebula 3.6

Description

Hi,
I often get this kind of message in a popup in Sunstone :

DataTables warning (table id = 'datatable_images'): Requested unknown parameter '10' from the data source for row 1

I've setup a fresh install from trunk today a 12h. Any clue ?

Jordan

Associated revisions

Revision bf4dd09d
Added by Hector Sanjuan about 8 years ago

Bug #1331: Some image states were missing from Sunstone helper.

Resulting in null being added to datatable and ugly message poping up on refresh.
(cherry picked from commit d69cbba21a4bfdcf6cdeb5f1a9668d95ba6550ee)

Revision 90220b6d
Added by Hector Sanjuan about 8 years ago

Bug #1331: Some image states were missing from Sunstone helper.

Resulting in null being added to datatable and ugly message poping up on refresh.
(cherry picked from commit d69cbba21a4bfdcf6cdeb5f1a9668d95ba6550ee)

Revision a9c767c4
Added by Hector Sanjuan about 8 years ago

Bug #1331: Fix image states in ozones too
(cherry picked from commit 162afa6d313a0fb752e3b0b3a63cbacd421d569b)

Revision d09f464a
Added by Hector Sanjuan about 8 years ago

Bug #1331: Fix image states in ozones too
(cherry picked from commit 162afa6d313a0fb752e3b0b3a63cbacd421d569b)

History

#1 Updated by Hector Sanjuan about 8 years ago

  • Category set to Sunstone
  • Assignee set to Hector Sanjuan

Hello, was the database also fresh? If not, can you try with a new DB?

#2 Updated by jordan pittier about 8 years ago

Yes, the DB (sqlite) was fresh.

This message seems to have no impact, I can still add new "image" through Sunstone and used them in templates. But sometimes when I list images in Sunstome, the list is empty... (weird)

I am using ruby-1.9 on debian wheezy. I will try to reproduce once more, in a brand new install of opennebula.

#3 Updated by jordan pittier about 8 years ago

Yes, the DB (sqlite) was fresh.

This message seems to have no impact, I can still add new "image" through Sunstone and used them in templates. But sometimes when I list images in Sunstome, the list is empty... (weird)

I am using ruby-1.9 on debian wheezy. I will try to reproduce once more, in a brand new install of opennebula.

#4 Updated by Hector Sanjuan about 8 years ago

whats the output of 'oneimage list -x'?

#5 Updated by jordan pittier about 8 years ago

I can't reproduce :(

The message appeared with Iceweasel on debian Wheezy in a test lab located far away from where I am now. I can't retest. You can close this issue, if I get further info I'll let you now.

#6 Updated by Hector Sanjuan about 8 years ago

  • Status changed from New to Assigned
  • Target version set to Release 3.6

I think I got it. It happens when image is in USED_PERS state (persistent+used) for example. Will upload patch briefly. Thanks for the info!

#7 Updated by Hector Sanjuan about 8 years ago

  • % Done changed from 0 to 100
  • Resolution set to fixed

#8 Updated by Ruben S. Montero about 8 years ago

  • Status changed from Assigned to Closed

Also available in: Atom PDF