Bug #176

Model not showing up for NIC

Added by Shi Jin almost 10 years ago. Updated almost 10 years ago.

Status:ClosedStart date:11/20/2009
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Release 1.4
Resolution:fixed Pull request:
Affected Versions:

Description

According to http://lists.opennebula.org/pipermail/users-opennebula.org/2009-October/001050.html and http://www.opennebula.org/doku.php?id=documentation:rel1.4:template, one can send a MODEL information for the NIC like
NIC = [NETWORK ="intranet" ,model='virtio"]

However, "onevm show" does not show a relevant line when it is used and the resulting VM does not use the virtio device for NIC.

Thanks.
Shi

one-1.3.90-model.patch Magnifier (741 Bytes) Jeroen Nijhof, 11/26/2009 09:09 PM

Associated revisions

Revision d0c705f6
Added by Ruben S. Montero almost 10 years ago

#176: Model is now added to the new nic, patch by Jeroen Nijhof

git-svn-id: http://svn.opennebula.org/one/branches/one-1.4@942 3034c82b-c49b-4eb3-8279-a7acafdc01c0

Revision 126bb99f
Added by Ruben S. Montero almost 10 years ago

#176: merge back NIC model patch to trunk

git-svn-id: http://svn.opennebula.org/one/trunk@943 3034c82b-c49b-4eb3-8279-a7acafdc01c0

History

#1 Updated by Shi Jin almost 10 years ago

I also tried to change the virtual network directory by adding a MODEL="virtio" line and it still didn't have any effect.

#2 Updated by Jeroen Nijhof almost 10 years ago

I had the same problem, and I fixed this issue.
The problem is that they replaced the template nic information with the new information getting from the leash function but that one will not give a model return so the orginal model information get lost.

Try the patch attached. It worked for me.

#3 Updated by Marlon Nerling almost 10 years ago

Jeroen Nijhof wrote:

I had the same problem, and I fixed this issue.
The problem is that they replaced the template nic information with the new information getting from the leash function but that one will not give a model return so the orginal model information get lost.

Try the patch attached. It worked for me.

I confirm it worked for me too, light changed, in version 1.3.80

#4 Updated by Shi Jin almost 10 years ago

Jeroen Nijhof wrote:

I had the same problem, and I fixed this issue.
The problem is that they replaced the template nic information with the new information getting from the leash function but that one will not give a model return so the orginal model information get lost.

Try the patch attached. It worked for me.

Thank you. I also confirm it works for me.

#5 Updated by Ruben S. Montero almost 10 years ago

  • Status changed from New to Closed
  • Target version set to Release 1.4
  • Resolution set to fixed

Also available in: Atom PDF