Bug #1866

opennebula rpms don't depend on rubygem-ruby-net-ldap

Added by Matthew Richardson almost 8 years ago. Updated almost 8 years ago.

Status:ClosedStart date:04/05/2013
Priority:NormalDue date:
Assignee:Jaime Melis% Done:

0%

Category:Packaging
Target version:Release 4.0
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.0

Description

As a result /var/lib/remotes/auth/ldap raises an exception if you follow the instructions here: http://opennebula.org/documentation:archives:rel3.6:ldap

Can this dependency be added to the rpm? Like most of the other ruby deps it is provided in epel.

Alternatively (since ldap isn't a mandatory requirement for opennebula) could the docs be updated to flag up that you will need to ensure that this present before ldap auth will work?

Thanks!

History

#1 Updated by Matthew Richardson almost 8 years ago

Edit: Just realised that it's deprecated in epel, which might affect this decision...

#2 Updated by Ruben S. Montero almost 8 years ago

  • Assignee set to Jaime Melis
  • Target version set to Release 4.0

#3 Updated by Jaime Melis almost 8 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

Hi Matthew,

as you have pointed out, since this gem is not available any longer in EPEL, we are not going to require that gem. However, we have followed your suggestions of making it more noticeable in the ldap documentation page of OpenNebula.

Also available in: Atom PDF