Feature #2243

Add html5 spice client alongside with vnc

Added by Carlo Daffara almost 7 years ago. Updated over 6 years ago.

Status:ClosedStart date:07/29/2013
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Sunstone
Target version:Release 4.6
Resolution: Pull request:

Description

A very useful feature is the ability to open an html5 vnc console directly from sunstone; however, this works only if the display is set to VNC.
A simple but reasonably complete html5 implementation of spice exist, however, and uses the same websockify approach currently used by vnc; the source code and context is available here: http://www.spice-space.org/page/Html5
I would suggest that it may be a valuable addition to sunstone; eventually, I would go and suggest that the icon of the console can have a little "vnc" or "sp" embedded to graphically show the different protocol used.


Related issues

Duplicates Feature #1711: Spice HTML5 client Closed 12/31/2012

History

#1 Updated by Ruben S. Montero almost 7 years ago

  • Tracker changed from Feature to Request

#2 Updated by Daniel Dehennin over 6 years ago

+1

Making test for virtual desktop solution show me the limitation of actual SPICE implementation.

Setting the SPICE IP:port avoid having “1 template to rules them all”:

  • 1 template to spawn a client
  • a user access the VM display, login and get his $HOME from network (typically NFS)

Regards.

NB: this looks like a duplicate of #1711 ;-)

#3 Updated by Ruben S. Montero over 6 years ago

  • Tracker changed from Request to Backlog
  • Priority changed from Low to High

#4 Updated by Ruben S. Montero over 6 years ago

  • Tracker changed from Backlog to Feature

#5 Updated by Ruben S. Montero over 6 years ago

  • Status changed from Pending to New

#6 Updated by Ruben S. Montero over 6 years ago

  • Category set to Sunstone
  • Priority changed from High to Normal

#7 Updated by Ruben S. Montero over 6 years ago

  • Tracker changed from Feature to Backlog
  • Status changed from New to Pending
  • Priority changed from Normal to High

#8 Updated by Ruben S. Montero over 6 years ago

  • Tracker changed from Backlog to Feature
  • Status changed from Pending to New
  • Priority changed from High to Normal
  • Target version set to Release 4.6

Moving this for 4.6

#9 Updated by Ruben S. Montero over 6 years ago

#10 Updated by Ruben S. Montero over 6 years ago

  • Status changed from New to Closed

Marking this as duplicate. Scheduled for 4.6

Also available in: Atom PDF