Bug #2537

Ubuntu source package tries to execute non existent build script

Added by Chris Cormier almost 7 years ago. Updated almost 6 years ago.

Status:ClosedStart date:12/03/2013
Priority:HighDue date:
Assignee:Jaime Melis% Done:

0%

Category:Packaging
Target version:Release 4.10
Resolution:fixed Pull request:
Affected Versions:OpenNebula 4.8

Description

When building from the provided Debian source packages the debian/rules tries to execute '../build_opennebula.sh' to compile the build. This script does not exist.

diff --git a/debian/rules b/debian/rules
index 4122e4d..5f82192 100755
--- a/debian/rules
+++ b/debian/rules
@ -20,8 +20,8 @ export LDFLAGS:=$(shell $(dpkg_buildflags) --get LDFLAGS)
dh $@ --with javahelper --with bash-completion

override_dh_auto_build:
- #scons mysql=yes old_xmlrpc=yes #parsers=yes
- ../build_opennebula.sh
+ scons mysql=yes new_xmlrpc=yes #parsers=yes

build_opennebula.sh Magnifier (569 Bytes) Jaime Melis, 10/15/2014 11:03 AM

xmlrpc-c.tar.gz (1.51 MB) Jaime Melis, 10/15/2014 11:03 AM

History

#1 Updated by Jaime Melis almost 7 years ago

  • Category set to Packaging
  • Status changed from Pending to Closed
  • Assignee set to Jaime Melis
  • Target version set to Release 4.4
  • Resolution set to fixed

Apologies, this script should have been included in the tarball. We have added for this release a sources folder: http://downloads.opennebula.org/packages/opennebula-4.4.0/Ubuntu-12.04/

In the future it will be included in the tarball.

Please reopen if this doesn't fix the problem.

#2 Updated by Jaime Melis about 6 years ago

  • Status changed from Closed to New
  • Priority changed from Normal to High
  • Target version changed from Release 4.4 to 67
  • Affected Versions OpenNebula 4.8 added

This issue is not fixed.

#3 Updated by Ruben S. Montero about 6 years ago

  • Target version changed from 67 to Release 4.10

#4 Updated by Jaime Melis about 6 years ago

This will be included in the final 4.10 packages. In the mean time, the scripts are attached to this comment.

#5 Updated by Jaime Melis almost 6 years ago

  • Status changed from New to Closed

Fixed for Debian 7 and Ubuntu 12.04. The static xmlrpc linking has been removed from Ubuntu 14.04.

Also available in: Atom PDF